Teams does is in a start up loop, mac OS 13.5.1

Copper Contributor


Suddenly MS-Teams can not start an sign in.

The Apps shows a connection error, terminate onself and stars up again, this in a loop.

Only way to quit this loop, restart the computer.

Anyone a solution to get Teams work again?  

10 Replies

@calore Have seen something similar.  Teams shows an authentication error.  The error displayed was “Error 1001.”  Issue was expected to be an AD SSO plug-in for Apple error.  If your environment is using the AD SSO plug-in, try bypassing Teams (or temporarily disable the plugin).  If Teams starts to work with no issues, then your situation may be similar.  If related, I understand it’s a known MS issue first reported in March 2023. 

Same at my Mac. Last week everthing was OK. No changes. Since yesterday Teams is looping on and on. Errorcode is 2002. Authentication failure.
I tried cleaning Teams Cache, complete deinstalation and reinstall, login on iOS (where it works), Login in Microsoft Customer Websites with SSO, switch of Microsoft helper in Preferences. Nothing was a solution. No more ideas left.

@calore similar problem here, where Teams is quickly cycling to several windows when trying to login to a meeting. Have to rely on browser for Teams meetings for now. Restarting the Mac helped at least once.

@calore Same issue here on my Mac. 

@Skizzik I have an update now. When I first opened the Teams app this morning, and then clicked the link to the meeting in iCal, I did not happen. Hopefully, that will be a simple workaround...

Thank you for this solution proposal. Unfortunately it does not solve the issue on my Mac.

@pannaert Thanks! 

I tried your suggestion and some strange thing happened, but it seems to have solved the problem (for now). I logged out, then logged back in to the Mac, then without launching Teams, clicked on a Teams link in the calendar. I allowed it to start Teams. Then the Teams application appeared, and the previous error window flickered very quickly, as if it was constantly restarting and restarting. I then somehow managed to pull the Teams window that appeared aside and click the login button there (I had previously logged out). After that, I don't know exactly what happened, but I had to select which user I wanted to log into Teams with, and then I think it let me in. I may have had to log out of the Mac again to get the flashing window to stop, but since then Teams has been running. It's kind of weird, and maybe the star positions and keyboard color matter, but it's worth a try :).

Since yesterday the issue does not longer appear. I did nothing also no automatic update has been happend. Microsoft must have fix something in the Backend.

I have the same problem here. (MacBook air, Sonoma 14.0) I have done everything (removing cache, deleting Teams, reinstalling teams, updating my software, restarting my computer) with no positive result.
I can login to teams with another account. Tried to add the account there, but then I get the same message I hav had several times: "Oops. We have run into issues while switching to the selected account or org"
I am completely stuck. I need the other account for being able to work with another team. I ran out of options. I tried to call microsoft NL, but they do not have the service by telephone anymore. Is there anyone out there who can help me out? Preferably Dutch speaking and reachable by phone. 

I have the same issue with my all users who is using MACOS (ventura, sonoma) even with new TEAMS but for the moment we have forbidden to use the new teams .
So we use the Teams Classic.(old version).
For the moment the the solution is :
Delete all the Teams Access in the MAC Keychain Access. then
Open the terminal on MACOS then type: rm -r ~/Library/Application\ Support/Microsoft/Teams
After that the issue is solved but not for a long time
because we continue to have the same issue few weeks later.