"Copy Link" to get URL to a file in teams keep spinning

Iron Contributor



I am having issue when I try to "copy Link" to get an URL to a file or folder in teams. It keeps spinning but not generate a link. I am using Windows 11 and latest Teams. I have even reset my pc, clean cache, and reinstallled teams. Still not working


I have no issue with this feature in my win 10 computer with same teams account. So I am sure this issue is associate with my win 11 only. 


Anyone can help






21 Replies
I've got windows 11 and it's working fine. How did you clear cache? Have you done a manually sign out and back in? That usually clears more cache than uninstall / reinstall for some reason. Gonna assume it works in teams.microsoft.com web?
Thank you very much. I cleared the cache according to the instruction online by deleting all the files in Cache folders. I have also reset my entire win 11 pc. Yes, I did manually sign out and back in. Nothing works.

"copy link" feature is working fine in team.microsoft.com WEB and my win 10 pc.

Any further suggestion?

Hi Ryan,

Did you have any luck with sorting this, we have a few laptops doing this since the last 6 days. Have tried logging out and back in, uninstalled and re-installed Teams. Fails to work.

Actually, it magically working from this morning. I am sure it was working yesterday
Hi Jin Chen,
We are getting this error now for users on Teams Desktop Ver. I tried clearing the teams cache, but no joy.
Any idea why it started working for you again? Thanks

I'm curious as well.  This began happening about a month ago to 1 user.  Today its another.

Logged out and cleared cache.  That didn't work.

Fully uninstalled, cleared all the Teams directories out and reinstalled.  No love.


Teams is up to date.  Can't seem to get this working again.  

@gt-sea  and @tclark_mpg I am experiencing the same issue, have you found a solution?

We have found a workaround for our Copy Link dialog box not rendering completely. If we switch networks, we have to log out of Teams and then log back in and the Copy Link dialog box will render and fill in.

For our users, if they move from their docking station to a conference room and wifi, they have to log out of teams and then log back in to Teams and then the Copy Link box renders for them. Same process when they leave the conference room and go back to their desks. Users with older versions of Teams do NOT have this problem (we've told them not to chk for updates) so this is something related to newer versions of Teams. We had no problems with the Copy Link function in Teams desktop 3 weeks ago.

@Lee-Lep No resolution yet, but the workaround is the user clicks Open in SharePoint, then gets the copy link from there.  

@Jin Chen 

I'm bumping this. Same issue on my side.


Still going on for us as well. 3 users and counting.
Copy Link button on Teams doesn't work, neither does the copy link button on a document/item opened within teams.
Web based works.
I'm bumping this. Same issue on my side.
I have been struggling to get this working. This is only a Desktop issue from what I can tell as I can get the link and manage permissions from the web version of Teams. This really stinks as I'm trying to build a whole document management strategy and Knowledge Management workflow using Teams, and this is really getting in the way of helping my clients adopt managing documents within Teams...

Also bumping this issue. Win 10 Pro 21H1 with all current updates. Teams desktop (64-bit). Clearing cached, sign out, back in, unistall/reinstall...none of that works. Copy link works on web and mobile.

@Jin Chen the solution that worked for me in the end was to log out of MS Teams on all devices (phone and ipad). When only logged on to my PC the "copy link" function started to work and it still does after I logged in on all devices again. Atleast for now :)


One day it works, the next day it fails....  Still an issue for us.

NOTE to Microsoft:

This option was rock-solid – NEVER had a failure - until Microsoft started making changes.  This change has been handled so badly by Microsoft and if you read the community pages for this change, users hate it.  They want to keep the Microsoft Teams option and not send a SharePoint link which is very confusing. 


How does Microsoft expect me to support them in this change?  The change has screwed us up for almost 3 months now and you’re removing a feature that my users love? 

Having the same issue and have no clue what to do. Will try empty cache and rejoin now.

@Jin Chen 


I'm having the same issue for a while now.