Microsoft Teams not displaying correctly.

Occasional Visitor

For the past week or so my Microsoft Teams hasn't been displaying correctly.


The closest thing I can relate it to is when a webpage hasn't loaded it's CSS correctly.


Everything is there, and Teams seems to be functional, but because of how large everything is, it's quite unusable.  Notice the scrollbar on the right to get an idea as to how large everything seems to be.




And if you scroll, you start to see things like this.  Everything is VERY large.





Does anyone know how I can fix this?


I've rebooted.

No change.

Uninstalled, then rebooted.

Reinstalled from the Microsoft store. No change.

Rebooted. No change.

Uninstalled. Rebooted

Downloaded the installer from Microsoft website.  Installed.  No change.

Rebooted.  No change.


10 Replies

I have the exact same issue.  It started happening the last few days of April 2020, or first several in May 2020.  Can someone please help?


I've also uninstalled, reinstalled, rebooted, etc. but that didn't help.


Here are a few images of my Teams desktop applications.  







@MarcHardAtWork I just tried "Troubleshoot settings"



Then Windows Store Apps > Run the Troubleshooter



It prompted me to enable User Account Control (UAC), which I accepted, then it ran and said it fixed some problems.  After that, I restarted Teams and it looks normal again.

Hi @DT_Work 


I am also having this issue with a users system works fine if i run as Admin but if I try and run as the user himself i get the same issues with Teams


Did all the same thing uninstalled.


Reinstalled multiple different types of install.


So it looks like the issue is in relation to the users level of authority in some way.


Mine user is a windows 7 user so i am unable to attempt the Windows 10 repair that was done.


Any other suggestions?







Issue has now been resolved after the latest update from Teams

I recently had the same problem and i tried everything as you did but it did not help me too.


Working on it for few hours i managed to find the solution, however i do not know the actual cause of this problem. I do not know if this idea works out for you or not but it helped me so i will share with you. Try if it helps you too.


When scrolling down the screen near to the end, you will see the pictures like of uploaded with this reply (i have attached them below), that indicate themes. If you are using one of the theme and you are having the misbehaving problem then click on other theme this is what i did and it came back to normal 


If those pictures do not appear then, on the task bar you will see MS Team program, right click it click on settings and try again it should show up then.

I hope it will help you 


Hi Rohit,


Thanks for the heads up it was only th eone user and a Teams updsate fixed it but ill look out fofor your suggested fix if the issue ever reoccurs :D





I too am having serious problems while trying to grade hundreds of papers. I am running the MacBook Pro 2019. Here are what all my student's tasks look like. Interestingly enough, when I highlight all the text, and switch the font to the bold "heading 2" on the top menu, I can see the text again. This doesn't work when I need to comment and correct hundreds of assignments. When I clicked contact support, I can't read anything. Also, when I make comment, I cannot see what I am writing. I've tried restarting, and I disabled hardware acceleration on Teams. Nothing helps and I have a lot of work to do. wordteams.png

@Teacher535 It appears that I have remedied the problem. What did I do?


I went to ~/Library/Application Support/Microsoft/Teams and deleted the entire Teams folder. I then restarted my computer and signed back into Teams. Now I can see all the text on an embedded Word document on Teams. 

i have a problem with join it does not appear in my device only.what is the problem and the solution


This is exactly my experience as well. ONLY the user in question is affected. I can even swap Teams accounts on the same local Windows profile of the affected user and Teams displays completely fine...