Microsoft Teams Not Asking for Password

Copper Contributor

I have the Microsoft Teams desktop app on my work station. This is a work station that on occasion is shared with other users. My problem is that when logging into Microsoft teams, it does not ask for my password. If you put my e-mail in it just logs straight in. This is problematic because I have access to files and folders that other users don't need access to. How can I reset Teams to ask for my password at log in?

31 Replies

@Runwilburrun Hey, Teams uses Modern Authentication and the process is described in detail here


Depending on your org. config you'll see what options are available for you.


Hope it helps, cheers.

@ChristianBergstromHello, I am facing same issue. Teams is just asking for email address without a passowrd and still is loading. At the end Teams suggested to log off and relogin. I tried every published sugegsted and also steps posted in but haven't got luck. It happens to different users in our company. Finally the Web version or App on mobile device is working well but not the Teams app on desktop machine. If I start Teams on desktop machine with administrative priviledges, it will work. But this is not an option for all users within the domain (domain.local).

Please help to investigate the issue.

@DoreenN Hello, you shouldn't use the Teams desktop app on computers with shared credentials, that is a single account that several people use on one computer. Teams uses modern authentication and SSO as described in the above link. You can prevent the auto generation of sign-in name but it won't remove the cached credentials. I suggest you look for other alternatives such as only Teams online, shared computer activation, virtual desktop etc. You can open up a ticket with the official Microsoft support for further information and/or read more about it at MS docs.

@ChristianBergstromHello, may that I wrote something wrong. It isn't the case that more than one user is working on a machine using Teams. There are no shared credentials being used.

In our company all user have just on machine running MS Teams but some are not able to use the Desktop app but on the Web app or on mobile device Teams is working well.

Now I am facing the same issue. As long as a will start the Desktop App with common user permissions as usual, I am not able to login as it is running in a loop. I enter email information but won't be asked for password. If I would start Teams with administrative priviledges it is working.

Hope this is a better problem describtion and you can help.




@DoreenN Hi, this could be one of many things.


Only for some users? Any the difference between them?

Have you tried to exit Teams completely (end process)?

Have you tried removing all cached credentials from Credential Manager?

Have you reset the app by deleting the Teams desktop cache? (%appdata%\Microsoft\Teams)

How does the account settings in Windows look like?

@ChristianBergstromHello, yes I know and therefore I tried a lot of suggested workarounds from people facing same issue in different forum.


Not all user, just a few have these kind of issue. We didn't found a difference in detail. All have same Windows domain and permisson etc.

Yes, I tried logoff from app as well as from O365, exit, killing prozess.

I didn't found anything in credential manager which belongs to teams. Just having virtualapp/didlogical which I deleted as well.

I deleted Teams desktop cache.

Not sure what account setting is mentioned but I am logged in with a Domain User and haven't got administrative permission.


Attached you will find the log. Any help is appreciated.



@DoreenN Hey, sorry for the delayed answer. I'm attending


What happens if you make a password change on the ones having the issue? 


Out of curiosity, how did you deploy Teams? M365 Apps or Endpoint Configuration Manager?

best response confirmed by ThereseSolimeno (Microsoft)

@ChristianBergstromWell, meanwhile I tried suggested workaround to start Teams in Compatibility Mode for Windows 8 and so far, it is working well.




@DoreenN Well, that shouldn't be the solution really. But I suppose you can use that until you figure the other stuff out!



Did you manage to resolve this? I am having the same issue and it is driving me mad. Browser works fine, but desktop doesn't. Uninstalled, reinstalled, cleared cache.etc... I also have another PC where the same login works fine on the desktop app. No sense to this madness.


I have the same login issue where it doesnt actually ask for the password anymore.


Any help, highly appreciated

Hi, please have a look at these pages.


'PowerShell script sample - Reset the autostart setting in Teams'


'Teams will always log into the domain-joined PC account' 

@RunwilburrunHi, I've discovered that this problem is linked to the settings.json file on the cache, so I've made a quick & dirty .bat:

del /Q %appdata%\Microsoft\teams\settings.json

that I launch at every teams exit at the end of my work.

This file (with the login problem inside) is automatically re-created at teams restart
It would be great to know where's ( inside that json) the option that permits the login without the password...

@fabianope This worked for me, Thanks

It help me a lot.. Thank you .. I tried hell of things but not worked. Need to delete settings.json always after quit ms teams.

@fabianope  Just wanted to say thanks; though my issue was slightly different. I logged the user out and created then ran the .bat file, but it was still signing me in. I ended up removing the account this way:


- Go to Windows settings > Accounts >
- Select "Access Work and School" > Select old work account > Click Disconnect
- Sign out and Sign in again. Go to "Email & App account" > Click on old work account and Remove


You may also have to do this in credential manager (I didn't.) 


Then, open up Teams and sign in, but when asked to "stay signed in to all your apps" click "No, sign in to this app only." 


That made the difference for me. 

@ldoderothere is no such option like "Access Work and School" in Win7 system, but the problem with no logout is the same.


Having the same problem just today. Using Win7x64. On home-based PC, but logging in using Work email account. Has had no problems until today when I changed my work password related to my work email account. Tried everything so far that I can find. Teams will open and display "get started" button. I click that and I then enter in my work email address. I do not get the pop up window any more asking me if this is a work account or personal. I no longer get the request for password popup box. After a few seconds it goes straight to the "Try Again" something is wrong screen.
I've gone thru and deleted every entry in Windows directory as well as Registry.
I have a Win10 laptop from the office and do not have and issue with it. I also do not have an issue logging on to Teams using web-app (both using my new password). There are no Office or Teams credentials on my home desktop Credential Manager. Very frustrating.
Is it possible to have this setting where ONLY your various previously logged in emails are saved, but any of them chosen on subsequent logins REQUIRE a password entry each time for each particular email account?

@Kiedisman I am facing the same issues.

At your first login on an organization, the TEAMs app asks if you allow your organization to manage your device. It does not matter if you check or leave the option unchecked, the behaviour is the same. It register your password in the Word or School Windows' account, and afterwards at every login it does not ask for a password anymore and login automatically.

It is even worse, if you log out on exit, but leave the option to run in background or run after closing the app, a Microsoft login window is throuwn every 5 minutes, which does not inform from what app it comes (I found out it was team by trial and error).

I understand it is convenient to teams in corporations, where only one person uses one computer, to have automatic or "modern" login enabled. But an increasing number of people are now working from home, where sometimes a family member has access to the windows account for some eventual needs. I classify as a bug not having a simple way to require a password, and that may prevent me from recommending TEAMs for many organizations that are now using Google solutions, which have its issues, but are much simpler and transparent in these matters.


1 best response

Accepted Solutions
best response confirmed by ThereseSolimeno (Microsoft)

@ChristianBergstromWell, meanwhile I tried suggested workaround to start Teams in Compatibility Mode for Windows 8 and so far, it is working well.




View solution in original post