Member added via dynamic group (Azure) need to wait almost 24 hours before team is showing in Teams

%3CLINGO-SUB%20id%3D%22lingo-sub-2118852%22%20slang%3D%22en-US%22%3EMember%20added%20via%20dynamic%20group%20(Azure)%20need%20to%20wait%20almost%2024%20hours%20before%20team%20is%20showing%20in%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2118852%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20problems%20with%20the%20member%20whom%20are%20automatically%20added%20with%20a%20dynamic%20group.%20They%20don't%20get%20the%20specified%20team%20in%20MS%20Teams%20for%20hours.%3C%2FP%3E%3CP%3EThese%20are%20the%20steps%20I%20took%3B(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fdynamic-memberships%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fdynamic-memberships%3C%2FA%3E)%3C%2FP%3E%3CP%3E-%20I%20created%20a%20Sharepoint%20site%3C%2FP%3E%3CP%3E-%20I%20created%20a%20teams%20associated%20with%20the%20sharepoint%20site%3C%2FP%3E%3CP%3E-%20I%20converted%20the%20members%20group%20to%20Dynamic%3C%2FP%3E%3CP%3E-%20I%20created%20a%20rule%20to%20Attribute1%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20edit%20a%20on-premises%20AD%20user's%20Attribute1(Custom%20attribute%201)%20to%20the%20value%20I%20configured%20and%20I%20sync%20this%20to%20AzureAD%20the%20user%20is%20showing%20in%20de%20members%20tab%20in%20Azure%20AD%2C%20so%20I%20know%20these%20configurations%20work.%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20when%20I%20go%20to%20teams%20I%20confirmed%20that%20adding%20users%20manually%20is%20now%20disabled%2Fnot%20working%2C%20as%20per%20design%20with%20dynamic%20members%20group.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20also%20see%20this%20user%20is%20now%20added%20to%20the%20teams%20in%20the%20admin%20panel%20of%20teams.%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%20I%20don't%20see%20the%20member%20in%20MS%20Teams(When%20I%20check%20with%20an%20Admin%20user)%20and%20the%20user%20is%20added%20almost%2024%20hours%20later.%20And%20also%20removing%20the%20user(deleting%20the%20custom%20attribute%20and%20resyncing)%20from%20the%20dynamic%20group%20takes%20hours(6%2B).%20I%20tested%20with%20a%20single%20user(different%20users%20each%20time).%20and%20everything%20is%20synced%20properly%2C%20I%20just%20don't%20get%20the%20Team%20in%20MS%20teams%20within%20an%20appropriate%20timespan.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2118852%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

 

I have problems with the member whom are automatically added with a dynamic group. They don't get the specified team in MS Teams for hours.

These are the steps I took;(https://docs.microsoft.com/en-us/microsoftteams/dynamic-memberships)

- I created a Sharepoint site

- I created a teams associated with the sharepoint site

- I converted the members group to Dynamic

- I created a rule to Attribute1

 

When I edit a on-premises AD user's Attribute1(Custom attribute 1) to the value I configured and I sync this to AzureAD the user is showing in de members tab in Azure AD, so I know these configurations work. 

Also when I go to teams I confirmed that adding users manually is now disabled/not working, as per design with dynamic members group.

 

I can also see this user is now added to the teams in the admin panel of teams. 

However I don't see the member in MS Teams(When I check with an Admin user) and the user is added almost 24 hours later. And also removing the user(deleting the custom attribute and resyncing) from the dynamic group takes hours(6+). I tested with a single user(different users each time). and everything is synced properly, I just don't get the Team in MS teams within an appropriate timespan.

0 Replies