Live event roles not applying

%3CLINGO-SUB%20id%3D%22lingo-sub-2231790%22%20slang%3D%22en-US%22%3ELive%20event%20roles%20not%20applying%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2231790%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20guys%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI%20was%20hoping%20someone%20could%20shed%20some%20light%20with%20the%20problem%20I%20am%20having.%20This%20is%20the%20first%20time%20happening%2C%20I%20am%20doing%20a%20live%20event%20where%20I%20invite%20external%20presenters%20from%204%20different%20domains%2C%20when%20assigning%20the%20role%20%22presenter%22%20to%20them%20all%20take%20it%20except%20for%20one%20domain%20(ironically%20Microsoft).%20Every%20time%20I%20try%20to%20update%20it%20it%20reverts%20back%20to%20%22Choose%20Role%22.%26nbsp%3B%3CBR%20%2F%3EAny%20suggestions%20would%20be%20greatly%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2231790%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2232512%22%20slang%3D%22en-US%22%3ERe%3A%20Live%20event%20roles%20not%20applying%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2232512%22%20slang%3D%22en-US%22%3EYou%20mean%20a%20Microsoft.com%20address%3F%3C%2FLINGO-BODY%3E
New Contributor

Hello guys,

I was hoping someone could shed some light with the problem I am having. This is the first time happening, I am doing a live event where I invite external presenters from 4 different domains, when assigning the role "presenter" to them all take it except for one domain (ironically Microsoft). Every time I try to update it it reverts back to "Choose Role". 
Any suggestions would be greatly appreciated.

3 Replies
You mean a Microsoft.com address?
Yes
Just to let everyone know that ends up in the same situation, where the role does not show up, and just says "Accepted" and leaves you to "Choose Role" all the time. It seems to be visual bug. I had a chat with one of the Presenters who had this problem and when they opened the Live event from Teams it was joining them as "Presenters", so no worries, just visual bug