I can't sign up for Microsoft Teams.

Not applicable

I have tried to sign up for Microsoft Teams with my personal Microsoft account but it didn't work. This is what happens

  • I go to
  • The title of the site says "Microsoft Teams - error occurred"
  • It says "You're not on Teams yet, but you can set it up for your organization"
  • I try to sign up
  • It says I already have an account so I click "Sign In"
  • The process repeats.

What do I do????????

24 Replies

Are you using a company email? 


Does your company have Office 365?

I'm signed into Microsoft, we have office but can't get teams. I get this then click go to webpage & repeat. It's an endless cycle.



@BlueKeyI seem to have this issue too. I used a personal emai ID to sign up. I keep getting redirected to signup again....

@aparnapratap  Same problem for me. The cycle keeps repeating and I am unable to sign in with a personal e-mail.


Also, sidenote: Microsoft wants me to go to Skype instead, but what is the point of pushing Skype as a platform, if it being phased out as an application? 

@mayhman @aparnapratap 


I went through this process myself to see what is happening, to say the user journey is pants is an understatement. 


1. Sign up for an account - which you seem to have done.

2. You are told "our not on teams yet, set it up for your organisation"

2. Click Sign up for Teams.

3. Scroll to the bottom of that page

4. Click Sign up for Free. 


Follow the prompts and that should do it. 


That worked for me. 



@Andrew Hodges I tried what you suggested. It takes me to Skype (which I already have an account for) and nothing happens. Clicking "Sign me up for Free" at the top or bottom results in the same dead end: Skype. 


In Teams app, it says go to your email for a link, but no email has been received.


Very frustrating.




Skype or Skype for business?


Regular Skype.



Not sure if that's in the browser or opening the Skype client but try in an in-private browser session to sign up and also try on a phone or another PC to rule out your issue.

best response confirmed by ThereseSolimeno (Microsoft)

This process worked for me :-

1) Sign up for free

2) When given the three options choose the last option eg company

3) Put in company name or any letter

4) Sign up


This will then launch the teams app ... took me a while but it's now working.

Whatever I do, the Teams won't let me start using it to join a meeting even as a guest.  It asks for me Microsoft account name and then says either I am already signed up so use another email address (mainly):

Someone in has already set up Teams for your organisation

Ask your admin to get you started with Teams, or set up another org in Teams using a different email address.

Use a different email address.

I am a sole trader.  It won't let me go on.  I get a blank screen.@ammcl74 

This did not work for me as I did get the three options.

Same here, endless redirect.  Not signed up, already signed up, sign in. Not signed up.  Ugh

Microsoft teams Sign Up process has been broken for ages and no one seems to care. What a piece of crap.

to further expand, the endless redirects is tiresome and a major time sink. What I am doing is telling everyone who wants me to attend meeting on teams is to use Zoom or Google Meet .... as there is no such crappy, non-informative & meaningless redirects
BTW I am trying this on Ubuntu 20.04 bu regardless of OS the web redirects are completely useless

This happened to me, and I wasn't able to figure it out until after I missed my meeting.


None of the above solutions changed anything for me, what ended up doing it was closing out of the desktop app before clicking "Sign up for free".


It's a pretty aggravating reason to miss an important meeting, so I hope this helps someone.

Haven't you created new tenant in O365 for fake organization in this way ?

From another thread:
"Can You try sign in from another browser or from an inprivate browser session!
It’s common that cached credentials messes up login experiences"

This worked for me.  I got options that weren't presented in the browser I was using, probably due to cached information.  Once you get around the cached info issue, you'll get additional options in the process and the key is to select the option to setup an organisation, otherwise it just directs you to use Skype 🤦‍:male_sign: