Error when trying to edit a cross-channel post

Copper Contributor



I'm trying to edit a cross-channel post but get an error message which is (translated from Dutch, so not sure what the English version is exactly):


The channels this message was send to can't be retrieved


This blocks the editing and even deleting of the message. How can we proceed from here?




4 Replies
best response confirmed by Therese_Solimeno (Moderator)



Having just tested in my own environment, you should be able to edit a cross channel post. I would recommend the following


1.) Check to make sure you can edit and delete messages in the messaging policy

2.) Check to make sure you can do this in alternative clients (mobile/web)

3.) Clear the cache, log out and back in and try again


If these don't work I would escalate to support to look into it. 


Hope this answers your question


Best, Chris

Hi Chris,

Thanks so much for your reply! I've tried (or to be fair - it's my colleague that has this problem, so he tried) the steps mentioned, but still he gets the error message.

Any other options..?


- If they can edit posts as defined by their messaging policy
- The message is coming up in every client desktop web and browser
- They have logged out cleared the cache and logged back in

And still have the issue it may have been caused by something like channels being deleted after the post was created. The solution here is to raise a ticket to Microsoft support via the M365 admin centre so they can investigate root cause. Would be great if the outcome could be posted back here

Best, Chris