couldn't sign into microsoft teams room but calender is synced

Copper Contributor

Hey everyone !  Although I have installed / updated the teams rooms app to the latest version and the calender is syncing correctly which means I am able to see the booking but still the device (Microsoft Surface) which has teams installed on it is not being signed in to teams and says Couldn't sign in to Microsoft teams. The other thing is that the "Join" button is disabled whenever I try to join the device into the meating.


Here comes some pictures for more info 


I would really appreciate any help.




Thanks best regards


12 Replies



@Graham Walsh may be able to help on this one - he has extensive experience on Teams Room and may have seen it before in the past and so identify a root cause


Best, Chris

Thanks @Christopher Hoard 

Did it work before @MasoodRaufi ? I would double check the licenses on that account and ensure you can sign in on a browser on the admin side with no issues or 2FA in preventing the MTR app signing in.

@Graham Walsh I have the same issue here on a new system. Four others work without issue and the account can sign in to the Teams online system or go to other systems without issue. But no account can get past the Teams login on this one HP system. I did some light reading through the Teams admin logs from the device and found only one error, repeatedly. "- info -- Failed to getHomeUserUpn value with error: Message: Unable to open RegKey: 0x2" It is running Windows 10 20h2 and the release. Looking through Azure, it is able to authenticate with Skype and Exchange but just can't get past the Teams part, which is very frustrating. I have a ticket in with Microsoft as well, but I don't expect a fast response. This system is new, and no accounts have been able to fully get through. All licensing matches the working systems. I even got HP to send a recovery drive and reimaged the system, but it installed Windows 1803, so after confirming 20h2 is supported with I manually updated it. Windows first then using the PS1 from Microsoft to run the app update. 

@kconway Funny enough I had seen the exact same thing on a system. It was working fine but decided to re-image the device.  It went back to 1803, it wouldn't sign in as it was which I knew, as anything 4.8 or lower won't work.  Updated to 4.6.x, installed 1903, then and 1909.  It just wouldn't sign in, quick look at the event logs didn't show anything.  Changed tenants and accounts, no difference.  I then started to leave it and let the nightly updates run, and suddenly it has signed in.  I do not know what update was applied or what, but it's working now.

@Graham Walsh I wish I was having the same luck. Working with Microsoft support now, we've done remote sessions and I have sent them a ton of screenshots and log files. Changed settings, modes, accounts, and still spinning my wheels. I feel like this should be something simple, but they're scratching their heads too, so we'll see. 

Alright it resolved itself. Working with Microsoft, we checked all of the settings for the device and the account, everything was correct. We confirmed the registry values and pulled the log files from the Teams Admin center. Everything was connecting except for Teams, but no valuable error logs were found. So a few nights ago it did the normal 02:00 restart and update process, but this time it got the update that brought in the Cortana feature, and it all started working. Talked with Microsoft some more and they do not believe the update fixed it, but that it was coincidental. They believe the actual issue was propagation of the account with their systems and something that neither they nor I could change or impact. It was not propagation of the user or resource account, but rather the MTR system software. The support tech said that it was something he had another ticket this week to deal with, that getting everything set up and seeing the rest of it working, you have to just let it sit online for about a week and it will resolve itself. Not ideal, but thankfully I was not in a position that this impacted my business.
Thanks for that update @kconway Oddly my system has reverted to not signing into just Teams. Calendar is fine. No matter what mode I put it in, it won't sign in. Account hasn't changed in AD etc as I control that in this tenant. Got a ticket open.
Can you still sign into the Teams web app with the account? Also, if you go into the Teams admin center, does the system show up there and can you pull a log file? I did mine and ran a search for anything with the words "error"or "failed". I also tried another, known good, account on the system with issues just to m sure it was the system and not the account.
Yes that all works signing in on the web. Visibility in TAC is another issue I have open.

What I just did was sign in with another account ok, then switched back to the broken account and it signed in fine. No idea why it would have worked now. Very odd.

@Graham Walsh I have the same issue however I have a little twist with mine.  I have spent hours with Microsoft support and send all kinds of logs, they checked all the settings and to no avail.  Here is what is happening for me.  I have a new system that cant sign into Microsoft Teams the app is running 4.10.10.  This unit is from Crestron so it part of their Flex series.  I opened a ticket with them and some time I reimaged the ASUS computer and at that point the app version was 4.7.x and it worked.  Signed into Microsoft Teams, we made a bunch of test calls, scheduled the room through outlook and everything was great.  However, at 2am it went and updated itself to 4.10.10 and it hasn't worked since.


Again, I have hours of troubleshooting with Microsoft and Crestron so I am open to anything here.







Did you try signing in with a different account (either personal or another resource account)? If I sign in with another account it works, then switch back to a broken account it then works. However, I've seen it fail after a reboot. Just tested again by signing out of a good account and back the dodgy account, all ok. Then rebooted and all ok now. Hopefully it has fixed itself.

@Graham Walsh I've tried in using my account and it still didn't work.  All accounts I've tried have worked with the web version.