Connectors missing due "creator of the team must have an online mailbox". What does this mean?

Occasional Contributor

So, I was trying to get Gitlab integerated with our new Teams (free) space. However, I wasn't able to find Connectors option. After little search in Docs, I found this to be the issue:


The creator of the team must have an online mailbox; otherwise, no Connector option will be available. This is expected behavior.


Is this related to the space being free? Microsoft account being used for this space is an account associated with self-hosted email, and not outlook. Is this the issue? In case I wanted to enable Connectors do I have to remove the space, create an outlook email, and recreate the space?

7 Replies

I don't think the free tier supports connectors at all.

@Vasil Michev, frankly speaking when I didn't find the connectors option that was what I assumed. But, then I found Docs referring to mailbox only and not referring to upgrade requirement. Also, upgrade page doesn't specifically mention anything about Connectors.

best response confirmed by mahmoudajawad (Occasional Contributor)

Hi all,

I managed to fix a similar string here with the RSS app. Tech Community member confirmed it worked


It looks like you can add apps which use connectors but can't manage them directly, however in the case of the RSS app you could back door to the connector management screen and remove it


To add - you may be able to add other connectors through there too

Best, Chris

UPDATE: I completed setting up a Connector and tested it and it's working.


@Christopher Hoard, yup. You are the man! That works for me too. Based on this I assume this is a bug and should be reported. I'll report it at my end. However, if others do report it as well it might get escalated faster.

We use Gsuite for our email accounts. We just setup an teams organisation(Free tier). We cant seem to find Connectors link in the channels "..." section.

I can see it being there in the free tier one in another teams organisation I am in where I am an owner and I registered the account with a Outlook account.

Is this a bug? 

Anyone has a work around? We cant seem to integrate Jira onto teams

Found a work around. 

Click on more apps. Select the app(In my case Jira)

On the popup click on Add to teams option(Below Open)

Select the channel you want to connect it to. 

Click on Setup as a connector option (Not just Setup).


It seems to be working for public channels only, doesnt seem to work on Private channels? If anyone knows how to get it working for private channels, please do comment down below. 

@Amaldev, so, I missed your earlier comment. As you see it seems to be a bug for sure. Not sure what is the logic behind this but it definitely is a bug. For private channels workaround I'm not sure as the RSS workaround submitted earlier by the accepted answer poster worked for me on my public channels, but there ought to be some way to achieve the same for private channels.