Cannot create a meeting with Teams Add In in Outlook

Copper Contributor

When I try to create a new meeting in Outlook with the MS TEAMS add in I get the following error "We couldnt schedule the meeting. Please try again later".


My office version is 365 home edition.

I am using a personal MS TEAMS account (not a corporate account).

The version of MS TEAMS add in is 1.0.19231.3

On the bottom I posted my log of the install of the latest version add in version.

My Outlook account and Teams account is the same.


I tried to log out and log in again into Teams, while Outlook was closed. This did not help.


Thanks a lot in advance for your support.


Kind regards

Dimitar Bushkalov

8 Replies
Teams requires exchange online for the meeting addon to work properly. Personal MSA accounts with free Teams use email which isn’t the same.

Teams requires exchange online for the meeting addon to work properly.

@Chris Webb is there any documentation about that? It's not mentioned here

We have Office 2016, Exchange 2016 CU13, users synced with AAD Connect, Office 365 E3

We were talking cloud so I said Exchange Online. Exchange Online is still part of Hybrid so technically it's still required, but in this case it was free Teams which didn't. From what I've seen people have handful of issues getting Exchange to work with Teams when it's not hosted Online, but they say it should work per the doc. I've never actually had that scenario to know either way.
Hi Folks, all you need to do is to stand iin YOUR calendar!
Open your calender with rightclick command open in new window, now hit the blue icon for teams meeting - magic :)


Hi. Tried everything above and still getting "We couldn't schedule the meeting. Please try again later"

Outlook version: O365 MSO (16.0.13328.20350) 64-bit

Team version: (64-bit)


Any suggestions?

@AlexB20  You may want to submit a ticket at our online tech support

If you want to schedule a Teams meeting for another user (delegated), then this article will help you:
I have the same issue, and this did not work for me.