Android phone stuck in login loop for account with previous organisation

New Contributor

Hi. I've recently joined a new organisation and want to have Teams active on my phone as I did with a previous organisation. Unfortunately, my app is stuck in a login loop, I can't log in to log out (my account has been deactivated) and I can't find any place to remove any further user accounts in the system.

 

Basically, I can't use Teams on my phone until I can find away to fix this. Any suggestions?

9 Replies
Same issue. I can't use teams at all the last 3 days. Please share any possible fix or workaround.

Just bumping this in case anyone has a solution. Quite shocked that no one has one, or even a suggestion!

Ι finally made it in my case. I uninstalled all the Microsoft apps, for the phone to forget completely the old email and I also removed the device from the Company Portal (do it only if the company portal exists in your case). After that, I installed again all the Microsoft apps and added my phone to the Company Portal, and from that moment Teams worked properly and stopped being stuck in the login loop.
Nice, I'll give that a go and report back
Clear app data on the device fixed Teams for me.

@@

 

1st step: Remove the microsoft authenticator app, if present.

2nd step: Uninstall and Reinstall Teams app. After this sign in, it should ask for the password.

3rd step: Reinstall microsoft authenticator app, if needed.

None of these solutions have worked for me. My organization has changed tenants and now my Teams is in a never ending loop to login and authenticate myself, outlook is fine.

@schwabbie 

SOLVED: Ultimate solution for me was to remove Microsoft Authenticator app from my phone. But I did all of the following:


1. Make sure you have 2-step (multifactor) authentication enabled before uninstalling the authenticator app.
2. Prior to Uninstall of each app stop the app and clear the data then uninstall all microsoft apps:
     a. Outlook
     b. Teams
     c. Microsoft Authenticator
     d. Company Portal
3. Reboot
4. Install outlook and add account, which forced me to reinstall Company Portal and SMS authenticate myself.
5. Reboot
6. Install Teams and add account.

 

Essentially I am not using the Authenticator app, hope this helps someone.

I just forced Authenticator to stop and uninstalled. Then forced Teams to stop and opened. Voila, I'm in. Now to start complaining about all the Teams work notifications.