Company portal failing to install error 0x87D1041C

Copper Contributor

Hello Everyone,


I have added company portal (offline version) from Microsoft store for Business and deployed it to 6 autopilot enrolled windows 10 laptops. All laptops are with same hardware & configurations. Out of all laptop, company portal application is getting failed in one windows 10 laptop. I have tried to uninstall and re-install it but it's showing same error every time in that particular laptop. 


However apps are getting published in company portal in that laptop. then why in Endpoint manager it's showing failed to install with error code 0x87D1041C.

16 Replies
So if I am reading this correctly you create an app to publish the company portal app to some devices and on one device its failing. Can you show me/us how you deployed it? as the error code you have is saying the company app isnt detected AFTER installation.
No, it's regarding Company portal app itself. I have added Company portal app (offline version) from Microsoft store for business and deployed it to few autopilot devices. and in one device it's showing company portal app failed to install with error code 0x87D1041C
Could you share a screenshot how you published the company portal app?
I have attached the screenshot below. Also I have attached the error screenshot in my main post

@Soutumi - did you find a solution to your issue?

Nope, I have raised this issue to MS support and they have collected logs last week. Now waiting for their response.
Same thing started to happen to me out of nowhere. My Company Portal App was configured as yours and functional until last week.

Now during pre-provision (white glove) I'm having the same issue and I can't figure it out what is happening.

If you receive a answer back from MS support let us know please.
Did you configured the app as an required app in the esp in the device phase? Yesterday we noticed the same thing... after removing the app as an required app in the esp .... the white glove worked. Normally we don't require the company portal app, but somehow it ended up in the esp as an required app in one of the tenants we administer
Yeap, my ESP is actually is set to "All" instead of selecting the required apps. It make me think that if I don't want block usage I should uncheck "All" and select no app at all?

Sometimes this Intune grind my gears.

Yet, you mentioned that the White Glove worked, but you succeeded installing Company Portal after all? I would like to enforce Company Portal to all my devices
Normally we are only requiring office/onedrive and some simple scripts converted to apps during the esp (it doesnt mean no other apps are going to be installed but…)And we are skipping the userstatuspage… so when the user logs in, within a few minutes the company app (which is device targetted and set as required) is installed within a minute or 2..
Gotcha... thanks for sharing the experience!
In the ESP page i have deployed office apps only and when user logs in, company portal will be deployed in a minute as I have deployed it as required app.
Also regarding the company portal app offline version failure, Microsoft said uninstall and reinstall it in user's laptop and while deploying choose license type as device. however I have deployed Online version of company portal and we didn't get any failure yet.

Thanks @Soutumi 


Odd thing is this was all working fine with Company Portal in offline mode (using a device license), it just randomly broke on a few tenants with an error that seemed to indicate a problem with the application.


Also noticed the app had a GUID for an app version, made me wonder if this was something to do with the new Microsoft store?


Never had an issue with the online version and was using it as a work around for a customer. I am working on a new tenant build so will see how this one goes.



We are also using the online version (required), so it installs when the user logs in.


As the online version can't install in device context




How Application Context, Assignment and Exclusions Work in Intune - Microsoft Tech Community


Well, Company Portal got back to work after all.

This error is very misleading. My problem was related to an unsuccessful deregistration of the device. Once I manually performed deregistration (removing device rash from Autopilot and re-importing it after deleting its traces in AAD) and re-made white glove, Company Portal was installed as usual.

Not sure why installation of Company Portal was stuck during ESP, but logs pointed to a different direction.