The form is updated recently. Please refresh the page to load latest form

Highlighted
Microsoft

Hi, can anyone help advise me on this error message people getting when trying to submit form? I've freshly copied the link to ensure i'm using latest link/version, still get it. Only thing I've done recently is copy the survey to use as the basis for another new survey, which is running fine, under a different name and link. thanks!

6 Replies
Highlighted

I am getting the same error. Did anyone find a fix for this?

Highlighted
Still looks like no up date, this was really embarrassing when the link that went out to my company didnt work!
Highlighted
Highlighted

We fixed the issue by rebuilding the form. This would be painful if dealing with multiple forms though.
Still don't know what happened though, it worked for 3 people who submitted and then the next day the rest of the staff tried and were all getting the same error. Tested on different machines, different we browsers, different staff and machines on and off our network. The only thing that fixed it was building an new form.

Highlighted

 


@Paul Taylor wrote:

We fixed the issue by rebuilding the form. This would be painful if dealing with multiple forms though.
Still don't know what happened though, it worked for 3 people who submitted and then the next day the rest of the staff tried and were all getting the same error. Tested on different machines, different we browsers, different staff and machines on and off our network. The only thing that fixed it was building an new form.


We also faced this problem, and nothing else worked than creating a new form as Paul Taylor mentioned above. 

 

Would like some comment from Microsoft to this...

Highlighted

We've had the same problem too on a form.    Was embarrassing given I am currently promoting a transition to O365.   We haven't resolved the issue yet.