Microsoft Forms broken branching


Hi All,


I have a form that has some basic branching which has worked without issue for the last month until today. When users filled in the form today, most have reported back that they were taken to the wrong sections, while for others it worked as expected.  


General information:

  • Main multiple choice question with 5 different branching sections.
  • When i click Preview, the branching all works as expected, however if i copy the share URL and follow the link i too get the wrong branching.  
  • Looking at the responses in excel, some times the same users get the correct path and sometime they don't. When some users have clicked the link, it has skipped the first question entirely and sent them down one of the branches without the option to go back. 
  • No edits were made to the form in the last 2 weeks. It functioned correctly for the last month, but it is failing for about 85% of the responses today.

Any ideas?

6 Replies



I would like a response to this too, I am also having the same issue, only for the past few days and on an intermittent basis, but on all 6 MS forms that I've created that use branching.  These forms have multiple users and its now incredibly frustrating. I have investigated and not been able to find any soutions as the form design is exactly as it should be and the forms have worked perfectly for the past couple of months. 

Any help would be appreciated! 



I'm experiencing a similar problem.  Branching is broken for me in the sense that the forms that I have created no branching is taking place.  Every field pops up, which is quite confusing to people trying to fill out the form.

@AWhyte   I am having the same issue.  Very frustrating / confusing for my team.  Following this thread in case a solution is out there.  Thank you

We are experiencing the same issue. Randomly jumping to the wrong section.

How can we raise this as a bug in Microsoft Office Forms?

I'm currently still having this issue. Is there a fix?
I see this is an older post, but am wondering if there was any resolution or workaround for the branching issue? I created a survey with quite a bit of branching, and every time I test out the survey it works without issue, but my team is reporting an issue where the employee is being required to select from a dropdown that shouldn't be available based on their prior answer