Failed to upload your file MS Forms

Copper Contributor



one hour ago i was able to upload files in my form, now i receive the following message: 

failed upload.JPG






Tried different types of files in different browsers, won't help.


43 Replies



I think the option to upload only one file may be enabled!

2020-03-04 13_01_29-Add questions that allow for file uploads - Office Support.png



@FabioO365GoD this is enabled, but that means from my perpective that you are able to upload only 1 file at the time during the time that your are filling the form. Am i right?


I tried to upload only 1 file, but get the same message.


Still getting the same error




yes you are able to upload one file at a time!

Check the size of the file you are uploading, Single file size limit: 10MB





I do upload 1 file at the time, and the size is far below the maximum capacity.

still get the same red lined text




Please, you can reload the page, share the screenshot and file extension



I dont know what you mean with file extension.
However, i've reloaded the page 120 times and tried to upload maybe 30 different documents. Tried even with smartphone to fill in the form, still same error.



I’m sorry but for now I’m unable to replicate the error.

I suggest you to retry tomorrow!

Hi @FabioO365GoD & others


still not possible. The error appears after +- 4/5 days.

So if I create a new form, i'm able to upload a file. After 5 days, i will get that error message over and over.




@Djarano I also am having this issue. Hopefully someone could help solve this.

Hi @jazfuente 


i think i figured out. When you create an upload question, the file will be stored on OneDrive or SharePoint (for Group forms). When you test the form with example files, they will be stored in a specific folder (Apps/Microsoft Forms). 

If you delete one of the above folders, there is no storage location anymore and you can't fix that afterwards. So that was hopefully the issue for me.


If you want to clean all the example upload you did (for testing), just delete the items itself but don't delete the whole folder where they are stored.


Check if this works for you.

I have the same problem ... and of course I don't delete the corresponding folder in OneDrive ... access changes don't work either. Team members cannot upload files: Error Message: "Failed to Upload your file" lg Gerhard

Cause for this is because you've deleted the destination folder where you save the originally attachments. Also don't delete the folder in a upper layer.
So the folder structure probably looks like: Apps\Microsoft Forms
Once the folder is deleted, you have to delete your 'upload question' and generate a new one for having a sync with the right folder.



I did NOT delete any of this folders, why should i? This folders are created automatically when create a upload-question to store the answer-files .... so of course i will not delete such a folder in onedrive. The right folders exists - the problem also ...

look at this forum ... the same problems ...

best regards

Hmm weird, it seems to be an issue from the last 2/3 months.

Try to give your colleagues access to the right folder, and then try to upload it again. What I already discovered, is that if you try a new solution regarding this problem, you should generate that question again. It has to do something with the folder destination, at least for me.

Other solution we will implement is, depending on your situation, is to upload any file related things on Teams, and copy a hyperlink in the Form. Then you don't have any upload questions anymore. Was the best solution for us, also as we integrated the form in Microsoft Flow.

Good luck


I have the same problem.

I'm a math teacher in Italy. With my class i have the same problem. I created a microsoft form that involves uploading files. I subsequently created a test activity on teams.

When the students found the activity and tried to fill in the form, they received the same message "file could not be loaded".

But if I give them the link to the microsoft form directly, they manage to load the file.

I don't understand the meaning of this thing: it's the same form!

In any case, I had to create a fake return activity on teams, where I put the link to the form. In this way we have circumvented the problem, but surely this is not the correct way to operate.

Why is there this problem?


PS: forgive my bad English


good idea, your solution ... but all in all unsatisfactory


Screenshot 2020-04-22 12.34.22.png

This is what happens when I try to open a Microsoft form inside Teams, which contains a question that requires a file to be loaded.
The translation of the phrase in the pink box above is:
"Some information is missing from the file upload question. Try reloading the page or recreating the question."
But as you can see I have specified how many files I want (one), the maximum size (10mb), the type of file (word, pdf or image).
But there are no other editable options regarding file uploading.

this is what makes no sense. And I can't find a solution.

All in all... it should not stay as it is.
I have posted it now in several forums and to the Microsoft Support out of Teams..
Time to wait and stay at homeoffice;)

Dear @Djarano 

This generally happens when the file location (i.e. OneDrive folder) is either deleted or inaccessible for any reason.

As a workaround, I would suggest to following these steps might help:

  1. Save all responses of your existing Form ABC (example in this case)
  2. Create a Copy of the Form ABC (this automatically recreates the OneDrive folder at backend)
  3. Step 2 creates a new Form named Form ABC (2)
  4. Delete the Form ABC
  5. Rename Form ABC (2) as Form ABC
  6. Share its new link (the url) and try uploading the file

I tried and it worked for me. Let me know, if this works for you.


Stay Inside, Stay Safe..!!