Problem Enable Macros on Excel

Copper Contributor

Hi Good days all,


We had some trouble regarding with enabling macros option on specific user.

Our issue regarding with "enable button" on Security Notice.



Our SAP Application generating / exporting Excel report with macro, and majority of our user capable to enable the macro to access the Excel files.


How to enable the macro button on excel application. Even we already tried to reinstall the Office application but no luck. But in the same computer we tried with other user profile it's work. Is there anyway 

18 Replies

@Natanael90 we face the same issue, temporary solution will just need to open any excel file with data inside and leave it (dont close the excel) than continue generate report from SAP and it will work. 


from there you able to view the cert, you can choose to import and export than place in trusted publisher in excel later, so you can run the report without any excel open.

Thanks for your reply, but can you be more specific how to import / export the certificate ?

Since we already tried your method, opening the excel doesn't give amy response to view certificate and import/export.


Show Signature Details link


View Certificate button


Install Certificate button


Choose the certificate place in current user under trusted publishers than ok


than you are good to go without any excel open also can generate report from SAP now. (please make sure you have excel open with data, only you have the enable button visible and the show certificate link)




Hi thanks for your response again,


How to enable the "Show Signature Detail" ? Seems our SAP doesn't produce any certificate while generating the report 


This is what i produce when tried to generate the report from capable computer. 

There is only Enable Button Macros without Signature details to export the certificate and put the certificate on problem computer.






It worked for me. Thank you so much for this work around!
I'm having the same problem but also with no "Signature Details" button. Any solution to this? SAP is a pretty huge necessity to a lot of organizations
@Natanael90 Hi, I’m facing exactly the same issue. Have you found the solution yet?
We have the same problem, someone solve this?
Dont have button show siganture details to see certificate and add certificate to trusted publisher.
We have SAP 7.60 patch 13.
If you can open Excel with macors. Then
goto View-->Macros popup shows macro list then click Edit
VBA editor will open then goto menu Tools--> Digital Signature

Certificate name: SAP AG click Detail button.
Details TAB click Copy to File

Then Import .cer file to Internet option --> Content TAB --> Publishers button --> Import
Check again in Excel - Option - Trusted Center - Trusted Publishers

We have the same problem, no digital signature when we open macros.
We have SAP 7.20 patch 5. This started after Microsoft updated a certificate in Excel on 8/3/2022 for Microsoft Windows Defender Advanced Threat Protection.
The only workaround is to open any Excel file in OneDrive before we export to Excel. We use AVD.

@WeFreeFly , thanks for the suggestion. I tried and got stuck when i opened Tools--> Digital Signature, there is [No certificate]. Any recomendation?





same with me.
anyway, I tried import cert from because I can't find SAP AG cert.
still error.
This worked for me with 7.40 and 7.60 and M365 excel.
Just few words additionally: in excel you may need to activate Developer Tab by customizing the ribbon and then go to VBA editor. SAP AG certificate should be imported into USER CERTIFICATES-TRUSTED PUBLISHERS.

hi @wonderbeef1905 I have the certification you need. Also i can show you how to get it.  Contact me  email address removed for privacy reasons

Hi, I already downloaded the certification, and I used in a arond 3 computers and it worked. Maybe works for you. I dont know if i cant post here the certification, but i can share you from my onedrive or something.
Ricardo me puedes enviar la info a mi correo email address removed for privacy reasons.
I know this thread is like 10 months old but has anyone found a solution to this yet on how to get a certificate that actually works?