Network Connection Error in Excel

Copper Contributor

I get the following error when trying to access Help in Excel.


Sorry, something went wrong. Please check your network connection and try again.


My wireless network is fine. I get internet access on my laptop and iPhone, so I know it is not my home network.


Any known issues?

21 Replies

I have the same problem.


Bob, as I live and breathe, and online with the Microsoft Support Rep, the network error went away, and Excel Help was working. Of course, the rep said perhaps a glitch. Ya think? Anyway, since MS Word Help was working, there was probably some issue with Excel. In the future, I suggested that I might trying rebooting my laptop, since I rarely turn it off. Still have one SSD program drive and 7200 RPM data drive.

Anyway, the rep regurgitated back what I already said...I would do (hard reboot) in the future. Smart guy. My suggestion to you is to leave Excel open for a while and allow the network glitch to perhaps reset, like mine did, or do a hard reboot and try again. Since the Help recovery last night, I just checked Excel and Help is still working.

Good luck!
Thanks, mine is working ok now as well!



What is a "hard reboot"?  As opposed to a reboot? 


I've seen this before several times. The M365 account is offline or there's an account error.
File | Account | Sign out then sign back in.


Doesn't matter about the subtleties of reboot types.

It was Outlook I was having the problem with, but same issue really.  Anyway.  Stooped and started Outlook again.  All working.  Sigh!!

I have been getting this problem for over a week with Excel and re-boots/restarts don't seem to make any difference. It is only in Excel as Word and Outlook are fine. ?????



Hard reboot is when you select Windows Icon at the bottom left, then select Power > Shutdown. After shutdown, you simply restart your computer/laptop. Soft reboot is Windows icon, and then Power > Restart, which means the computer does not shut down or turn off. It just reboots warm (with power on).  Hope that helps.

You might try letting Excel sit there open for a while. Help did not display initially, but after some time period, it displayed in the app. Obviously, even O365 reps don't know what the issue is either. Mine just started working after several minutes with Excel open.
Problem not solved. No help Reboot and wait does nothing been like this for weeks.

@kweatherford I have the same error. Tried xx suggestions.   None worked. Then, while working on a sheet, I opened a second instance of Excel.  Help worked in that one!  Went back to the first instance and Help still fails.

Who ya gonna call?

You may benefit from knowing I tried running the Microsoft Office rebuild. At first it didn't seem to help. I would F1 and there was no change. But later after loading Windows and Office afresh I hit the F1 help key while looking up a formula and instead of opening the local help it opened up the edge browsers to the web help page for formulas. I prefer the old local help that took us to context specific help.   @CarverDan 


I did not do a rebuild but Help is now working.  Help is usually local but it is Edge in one case as I found.

I noticed in Programs there is Microsoft 365 and Microsoft 365 (Office).  I am new to 365 so I don't know why there are 2 entries.  Is it because 365 can run local or on the cloud?  Any way, if I use Microsoft 365, the only 'Recently opened' files are on onedrive  When I select one, it starts in Edge, running  If I place the cursor on the name of a dropdown, e.g., Functions and press F1, I get help in Edge.  But, if the cursor is anywhere else, other that a drop-down heading, then I get local help.

When I run the other Programs entry, Microsoft 365 (Office), it is different behavior.  First off, the 'Recently opened' files are both Onedrive files and the files on my PC.  I select a file and the Excel window looks the same as above but it is not under Edge. (It's running in the cloud??)  When I press F1, no matter where the cursor is, I see local help.



I ran into the same problem, and solved it by logging into my 365 Account.

Here are the steps using Excel:

At Home, locate the Account


Then click on Manage Account.  Sign on to your 365 account... which should take you to the account landing page,



Go back to your app, and try clicking Help once again... I was surprised to notice Help was there.


If anyone from Microsoft is listening, might I suggest some bits of Help (such as this) should be accessible even if not logged on - to reduce the frustration of paying customers.



I too have encountered this issue many times in the past few months. I tried the "Manage account" solution @dbliss147 suggested, but that doesn't work for me.


I found closing and re-opening Excel get it to work a few times, but only for a few minutes since restarting Excel. Work with Excel for a while, and it gives the error again. Perhaps a network trace will help to see what packets are being sent and to where. It could be a DNS error or some incorrect path.


It's definitely not an Operating system or networking problem. Everything else is working properly, even functions within Excel such as "Get Add-ins" which reaches out to other network servers.


For info, I've also had the same issue in MS Word and on different computers and networks.


Very odd and frustrating.

This has been annoying me for months, and finally I decided to persevere.  None of the suggestions here or other threads worked for me.  My Account seemed fine, there was no FIX button. I tried logging out and in again.  I have Office 365 so Excel doesn't even show separately in the Apps and Features section.


What DID work was opening Excel in Administrator mode - F1 worked immediately.  I then closed and reopened Excel normally, and F1 still works.


Hope that this helps someone.


Excel is on the latest version and the problem has existed through multiple versions for the past year. Same on three different PCs. It works a few times, then it fails. Close Excel and re-open and it works again.

This intermittent fault makes it hard to confirm any solution actually helps solve the problem.

@kweatherford I had my router network labeled as 'Metered' and changing that to not metered allowed me to access online help from the local Excel 365 App

Thanks @Matt_V1V

Unfortunately that's not my issue. It fine when I restart the app, but only once or so, then it gives the error again