Microsoft Excel is waiting for another application to complete an OLE action

Copper Contributor

Hi there,


Whenever I copy paste special in excel, my excel file freezes and after a waiting for a few seconds to few minutes, depending on the amount of data being copy pasted, I get this error 'Microsoft Excel is waiting for another application to complete an OLE action'


I tried a few things like this but none help and the problem persists.


1st troubleshooting

1. Open the Excel sheet and go the File menu. In the File menu, click on Options.

2. An Excel Options dialog box will appear. Go to the Advanced tab and scroll down to the General area. Over there check Ignore other applications that use Dynamic Data Exchange (DDE).

3. Restart Excel.


2nd troubleshooting

Tried opening Excel in safe mode


3rd troubleshooting

Removed all the Add ins


4th troubleshooting

Reinstalled MS Office.


Can someone help.

39 Replies
that works, thanks so much for sharing


I have the same persistent problem, it's very annoying when I try and open excel spreadsheets and have to consistently wait for the OLE action and I've tried all the options you've listed as well.



If you are using Google Drive File Stream you need to turn off "real time presence" in the Google Drive settings.


I found this info here

This might be an old issue but my recent experience with this error:

Testers with my macro got this error and the issue was testers did not have modify access to the network folder where workbook was opened and saved. Hope this helps.

@nileshparekhJust a note that the Azure Information Protection plug in may also be causing it.  Disabling it fixed the same problem I was having for a user on our end.

@Live_Undead Where do I find this Azure Protection Plug?

I tried to find "real time presence" in my google drive settings and I can't find it.

@teribryantGo to the Office app in question (Excel, Outlook, etc), then go to File-->Options-->Add-Ins (left hand column near bottom)


IF the Azure Information Protection plug-In is there, it will be listed under Active Application Add-Ins at the top of the box.  look down to the bottom of the open window where it says "Manage", and change that to "Comm Add-Ins", and press "Go".  In the window that pops up, uncheck the Azure Information Protection plug in, and press "okay".


That worked for me when troubleshooting a client's Excel.  But there are several things that cause this problem, so I just wanted to get the FYI out.




This is what I found in Add-ins and it didn't have anything checked except the Acrobat PDFMaker or the tool you were talking about.


Ah, then this fix doesn't apply to you. I'm sorry, but best of luck in figuring it out.
Thank you so much for your help, I really appreciate it!

The main problem is not solved.


None of the solutions proposed here are permanently solving the problem.


Also, I suspect that also the causes mentioned here are not the relevant ones since I'm getting this error also from different unexplained setups.


I have a MS 365 Business license; I pay a lot of money for their Excel and surprising a very annoying and time consuming problem is not solved for such a long time.


Very disappointing ...

I totally agree Go3th3! It's very frustrating!

My solution was disabling the McAfee real time protection. I turned off the Real Time protection in McAfee Live Safe before opening the excel file and the issue was resolved. @AshaKantaSharma 


New problem for me which only started yesterday. I have also finally managed to open my spreadsheets after turning off (temporarily) McAfee real time scanning. Thanks for the tip!

Worked for me too. I didn't connect this problem with the McAfee update. THANK YOU!!!
Unfortunately, this doesn't work for me because our district technology department is in full control of our virus protection program and it is not McAfee. Thank you!