File is locked for editing by 'me' issue

New Contributor

I am the only one who uses the computer and the file is stored locally and NOT on a server. I am NOT part of any work domain as it's my personal PC.

 

When I open the Excel file, I get a message saying that the file is locked for editing by 'my name'. There is no owner file (~$doc.xlsx) and I even rebooted the machine and still the same issue.

 

Even I renamed the file and still the same issue. Saving as a new name also didn't help.

I searched for solutions and nothing seemed to help. Any ideas folks as I am going nuts!

 

Btw, I am using Excel 2019.

 

I get the "File in use" message and click on Notify and after a minute or two, I get a message saying it's available for editing and when I click Read-Write, it says that the file is locked for editing and asking me to click on Notify. 

 

Btw, the file has a password on it and could open the same file on other computers. When I save it as a new file after removing all the personal properties, I could open the file on the affected PC. The minute I slap a password, it throws a violation error!

 

I could put a password on any other file and it opens fine. Only this file, which has lots of sheets, doesn't play ball with a password! Wonder where Microsoft is checking for the violation!

 

PS: I could work on the file without a password on it.  Just adding a password throws fits!

1 Reply

Hooray! Problem Solved!

 

Malwarebytes premium was blocking it all this time and I am NOT sure what they were trying to protect me when I am entering a password for the file. I disabled Excel Macro 4.0 Abuse Prevention in Malwarebytes and voila, I could open the password protected excel file.

 

Wow! Have to find out from Malwarebytes why this is even happening and that is for another day!

 

I must have wasted at least 6 hours, went as far as uninstalling/reinstalling 2019 and 2013 too. Crazy and finally solved! Whew!!!