Excel will not let me click into cells or incorrect cell is selected randomly

Copper Contributor



This is an ongoing issue that I've been having for years across platforms, computers, versions of excel and workbooks.


Basicially, one of two things happen:

1-I click on a cell but nothing happens, the cell is not selected

2-I click on a cell but the wrong cell is selected (Example: Click on cell B2 but excel will select C2)


This will happen as frequently as a few times a day (across multiple workbooks) to every month (again, across multiple workbooks)


In ALL cases cells are NOT protected


Saving the workbook, closing then restarting excel fixes the problem.


As I mentioned before, this has been ongoing for years now across multiple computers, workbooks, operating systems.  All systems and versions of excel were fully up to date at the time of the error.  Because this is happening over several different workbooks, I do not belive it is a workbook issue (especially when it doesn't happen 100% of the time to ANY workbook)


Systems used:

Macbook Pro (circa 2015), OS up to date - No longer have this computer

Windows 8 (again, old computer)

Windows 10 (old computer

Windows 11 (2 different computers, currently owned)

I have always kept excel and the OS fully up to date and I'm currently using the most recent version of Windows and Excel.


In all cases, I have used built in trackpad and a 3 different wireless mice (with full batteries).  Still randomly occurs.


It's really just an annoyance and like I mentioned before, saving the workbook and restarting excel solves the issue...  until next time (which could be later that day or a few weeks...It's very random.)

89 Replies


According to what has been written, edit mode might be activated.

But without a file (without sensitive data) it is difficult to make assumptions, especially in this case where it goes through many Excel versions. 

Edit cell contents


If it is not, many questions arise beforehand.
Does it only happen in this file?
Does this file have macros?
Are add inns enabled?
Have all updates been carried out?
Has an Office repair been performed?


Anyway, hope this information helped you a bit.



I know I don't know anything (Socrates)

Thanks for the suggestions.

Regarding files, it does not happen to every file and files that it does happen to it doesn't happen every time.

Next time I do experience this issue I'll check to see if it's in exit mode or not. In the meantime, I'll do an office repair and hope it's a non issue going forward.

To your specific questions:
*Random files at random times. I have a couple sheets I use VERY often and those are the only files I noticed the issue more than once. And yep, sensitive information ;)
*Usually no macros (I only open one file with any regularity with macros. Oddly I'm not sure I had the click issue with that file.)
*No add INS enabled
*Always updated (Windows and Office apps as well as any drivers, etc.)


The function row that used to show up automatically in previous Excel versions appears not to be in MS365. I type and edit text quite frequently in Excel. I am unable to click text in a cell to correct a typo. This is incredibly frustrating and step in the wrong direction in my opinion.


I am also facing the same issue with one of my systems which is currently running Office 2019 and Windows 11.


I was able to figure out my issue. The formula bar was not showing. It was a setting issue
To Show Formula Bar - Options/Advanced/Display/Check show formula bar
I've had the same issue. It also seems to be related to scrolling to quit working (like scroll-lock is on). It seems to happen with hidden columns and freeze panes.

I can't believe MSoft employees haven't run into this.
I've found for me the easiest "workaround" is to click on another open window and back into excel.

Tried all the usual stuff to fix it (uninstall and reinstall excel, back to defaults, etc. Even went so far as to reinstall windows and eventually purchased a new computer (not as a resolution...it was time))

Has there been a solution to this?  This started happening to me after Windows 11 update.  When panes are frozen and I click on a cell it randomly selects another cell.  For now clicking another sheet and going back to your worksheet seems to "fix" it, but it keeps happening. 

No fix for me. Windows, Excel and all drivers are up to date on the THREE computers I'm experiencing the issue. It does seem to be some sort of "focus" issue with my pointing device (mouse on desktop, mouse and trackpad on laptop #1 and trackpad on laptop #2). Clicking in some other window "works" every time...until next time. I have not found a consistent reason as to why it's been happening. Once I had the issue on a clean install of windows on a blank sheet!

@CPeterson710 - There is an excel bug that is supposed to be fixed with the Oct update that relates to using a touch pad to zoom and scroll.


But I see this is happening with mice as well.  

It's November and I still have this issue (agree with CPeterson and others -- nothing works consistently). Very annoying and time consuming. Microsoft should have been on top of this several years ago
OMG, this is doing my nut!
I have a simple sheet with frozen panes. The scrollbars are not updating/refreshing the visible cells so a click selects something but it's where Excel *thinks* it has scrolled to, just the screen render has not updated so it's very confusing. My Office updated to v2211.

@CPeterson710  I turned my (new) mouse off and I seem to be able to select cells using my trackpad now. I was having the same issue even with my trackpad while the mouse was turned on. It's an ergonomic "Perixx" mouse, Model No. Permice-608, for what it's worth. 

I had faced this issue some time back on one of my laptops, and cannot recall, but managed to circumvent it. Have now started facing the same issue since a fortnight on my laptop with Windows 11 and Excel 2019, and it is driving me crazy. Clicking on another window and back into excel works, most often. Clicking on menubar and then into cells also works sometimes. But nothing works consistently, and it is killing my productivity big time. Someone please help!

Tried this, but it seems this is NOT the problem in my case. Earnestly looking to a resolution of the problem...
This is an utterly disgraceful bug and must be resolved immediately. I've had 5 weeks of disrupted work and lowered efficiency.
Can someone with this issue please try changing their default printer? (We had a case open with Microsoft where this might have been the workaround.) Even though the issue has nothing to do with printing, this is a possible workaround.
Hello @CPeterson710 and All,

By any chance are you using a Wireless mouse/Keyboard combo? If yes it it the Logitech MK series?

Let me know please.