Excel freezes when formatting cells

Copper Contributor

When I try to format a cell in Excel - bolding, underlining, switching font size - the program freezes and I need to re-start.  Is a new issue from last 2 days having worked without problems previously.


I've tried program repair, updates and re-installing Office and running in safe mode.  No luck.  Any suggestions for how I solve?


Many thanks!


44 Replies
Unfortunately, I can't help you there. The only thing I have to offer is an old ticket through office 2016 with roughly the same problem. Take a look, maybe this will help you.

I know I don't know anything (Socrates)
best response confirmed by NikolinoDE (Gold Contributor)
This may sound ridiculously simple, but try to change your default printer to PDF. I have suffered from the same problem and this helped instantly.

@Emiru   Thank you. Thank you.  I just had the same problem for the past 8 hours.  I went in to set my default printer.  I did not have one set.  I had powered down my printer the night before.  I set the default printer to the pdf option.  It worked.    Thanks, again. 

@Emiru Brilliant. Have been having this problem for a while (may be because I am still using Windows 7). I Changed the PDF printer to default and all is now fine. Many thanks!

can't imagine how on earth you ever figured this out, but i'm glad you did, worked perfectly, thanks!

@charlie1volley Very strange, but that does appear to work.  I just changed my default printer to Microsoft PDF and the format cells no longer pauses/hangs Excel for 40-60 seconds.  Great workaround, now let's see if the good folks at Microsoft can fix that one :)


This just happened to me today and the solution worked! Thank you!!

@THill9999 Where? Where do we set this? In Excel Print dialogue? Or in Windows Printers? TIA

I solved my issue by going in Excel and selecting File, Print, Printer and selecting a printer.  I did not have a printer listed when I experienced my issue.

Hi @MarioPetrella, on windows 10 I just went to Settings > Printers & scanners > select: Microsoft print to PDF under the list of Printers & scanners > click: Manage > select: Set as default.  When you go back to the Printers & scanners menu, it should say Default underneath Microsoft print to PDF...

@charlie1volley  Thanks! 


I found that I needed to make a change in Windows settings; but ... 


After I failed using the Print dialogue in the app (that also caused a hang), followed by being unable to get a "make Default" dialogue within the list of Printers, AND showing no printers in Settings. (I did, however, see a check box for allowing Windows to manage Printer selection. 


So, what I did to resolve my issue was to first re-Start the machine; then when I came back up I was able to right-click on Microsoft PDF among the list of Printers in the File Explorer window, and set that as the Default (at this point I received a dialogue informing me that Windows would no longer Manage my printers for me). 


So it looks like, in my case, some change occurred under the covers that cascaded into the issue I was experiencing. 


Thank you to all for assisting correcting my problem! 


Thanks it works, Microsoft sucks!!!

Wie kann ich eine 15 spaltige und 1000 Zeilen Datei mit unterschiedlichen Zahlen von 1-300 so reihen, daß alle Zahlen aufsteigend in der Zeile gereiht werden

@Tim_Hill2190 so we are now a year on from this issue being highlighted and Microsoft still haven't issued a simple fix?  Don't they monitor this community??  Obviously too busy working on Windows 11 which is going to be just horrendous for most of us.

I am also faced the same issue you just have to restart Print spooler service and issue got resolved. 



Thank you for your feedback.

I would be happy if you would describe the steps (what exactly you did) to us.

This would also help others here in the forum.

When describing, please also describe the digital environment.

Office version, operating system, storage medium (hard drive, OneDrive, Sharepoint, etc.), printer model.


Thank you,


I know I don't know anything (Socrates)

This worked for me! :)
Many many thanks!! Can't imagine how on earth you ever figured this out, but i'm glad you did. It works!

@Emiru THANK YOU! I cannot believe this issue still isn't fixed!