Data from 365 list

Occasional Contributor

I need to export data from a Sharepoint list to an Excel file. The Sharepoint list is located on a site belonging to an organization which I have access to through a user ID. After clicking the «Export to Excel» a file in iqy format is downloaded to my PC.

Microsoft 365 is installed on my PC through a personal Microsoft 365 account. This account has a personal userID which is different from the userID I use when I access the Sharepoint list.

When I try to open the iqy file, I get this error message: "An unexpected error has occurred. Changes to your data cannot be saved."

This error message is very general and gives me no information on why the operation failed. I need to know the reason, or at least I need to know what the requirements for Excel exports from Sharepoint lists.

Can anyone help?

7 Replies


iqy defines how to import data from SharePoint and how to sync it. With another account it can't sync and give such error. You need to use account which has access to SharePoint.


@Sergei Baklan 

I have now logged on my Microsoft 365 with the userID I use in the organization holding the list I want to export from. Unfortunately that did not help. I got the same error message.


Any other ideas?


Do you have access to SharePoint from that computer? If so you may try to generate another query from scratch to check if it works.

I do have access to Sharepoint from my PC through the userID I use in the organization. It is I who created the Sharepoint list. I have tried many times to export the list data to Excel. Is that what you mean by "generate another query from scratch"?


On that computer select any list on SharePoint, click Export to Excel, open downloaded iqy file, enable data connection on prompt. If connection works you have the table in Excel workbook. 

This is exactly what I have tried many times, also with the organization userID on my local 365 Excel.

I now also tried to create a new list, then exported the new list. However, same error message again when I tried to open the iqy file.
I still have not been able to resolve this. Do you have any other suggestions?