Copy/paste no longer working in Excel

Copper Contributor

Sometime in the last few months the copy/paste function within Excel (Office 365 version) stopped working for me.  I have updated Windows and all Office apps to the latest version but that hasn't fixed the problem.  I've also run the Office 365 


The symptom is very strange.  When I hit Ctrl-C (or use the drop-down menus) on a cell in Excel the dashed lines that surround a cell selected for copying show up very briefly but immediately disappear.  If I go to another cell and paste it just puts a open parenthesis "(" in the cell.  Using Ctrl-X to cut exhibits similar behavior.


If I repeatedly hit Ctrl-C it will occasionally work (the dashed lines remain and I can paste) but it typically takes 15-20 tries before it will work and if I try again it will fail.  This only seems to affect me when I try to copy cells.  If I select a cell and then edit the cell and manually select the content of the cell I can copy and paste with no issue.  It also appears to only be an issue when a cell is not empty.  If I select an empty cell I can copy/paste just fine.  If I select a cell that has been highlighted but has no content that also works properly.  It's only when there's text or a formula in the cell that this is an issue.


This only affects Excel, I haven't observed the issue in any other app.


Any ideas?

102 Replies
Do the suggestions by jbosari on this page help?

Hi Jan, none of the methods work.


Below is a sample of my freshly formatted PC and freshly installed Microsoft Office 2016.

What I did was:
1) Select the A cell and press Ctrl+C

2) Select the B cell and press Ctrl+C

3) Select the C cell and press Ctrl+C




As you can see, there is this bracket ( somehow automatically copied on top of the A/B/C selections. This is really weird..

In that case I am out of ideas I'm afraid!

I have had the same problem, complicated by the "excel not responding" issue.  

In an effort to solve that problem, I changed some settings under options.

Well, then my large workbook quit behaving nice.  I would copy a row to one or more rows and all I got was the results from the copy reappearing in the new rows.

Well, that was cured with switching the calculations from manual to automatic.  Fixed the copy paste problem!  Did I feel dumb?  You bet.  I faintly remember using the manual calculation on a large worksheet from 20 years ago...

Now onto the "excel not responding" issue.  I've been trying to dump tons of formatting (color, borders, etc.) and checking for those stray columns/rows that had accidental formatting.  I saw that in one of my searches on google.  It seems to help, except in the process, the message comes up again and sometimes doesn't clear for hours, even overnight.  It's hard to dump formatting if you can't access the file and save your changes.  I have been dealing with recovered files, multiple saves and so on.  Sigh...  I may have to start over with these files and recreate them.  They are great grade calculators, with a sheet for each area (homework, attendance, quizzes, etc.) and pull into a summary page for final results.  Lots of "vlookup" action between sheets.  The fancy formatting with colors, borders, boxes helped to avoid errors with data entry.  I teach large classes (100+) and this has evolved with each graduate assistant, computer, software change over the past 15 years. Probably quite a patchwork job by now.  I might be on the road to sanity if all of this works.

I hope the manual to automatic switch in calculations works for you.  Good luck.    -  Marie



I had the same problem. The only way I could copy cells was text only via the clipboard.

The solution for me was to disable (comment out) all macros and VB content I generated for that particular page. (I use a nifty little bit of code to insert the contents of a cell into the footer of the page.)

I did my copying and once the page was working I removed the comment ticks and everything worked.


Hope this helps..

I have had this same issue in all Microsoft Office products, and I just had the same issue happen in OpenOffice Draw! It seems to happen with a document that I have been editing over and over again. Opening a new document does not seem to help the issue.

Hi all,


I had this same issue and was disappointed to get to the bottom of the page with no answer. 


However, upon saving & closing the most recent workbook I was working on, the copy paste functionality was restored in the new sheet I was working on that lost the ability to copy/paste.


This is really frustrating, but I think all we need to do is be a bit more organized and not leave workbooks open that we're not working on. That's my new protocol anyway. Hope this helps.



I have found the problem with copying from Excel cloud and to a local MAC screen i.e. a multi cell with a value to say notes.


The solution which is not one, but highlights the issue, is that you can double click on a value in Excel and copy from the bar, as below and it works :weary_face: but if I try and access and copy directly from the CELL it does not work at all, which is the existing problem. Not really a workaround, but does highlight what is going on !!


OK, guys none of these fixes worked for me. This just started for me today. In too different instances. When I copy the formula into another cell from another spreadsheet, the formula shows, but the result in the result from the cell I copied it from. he only that has worked is by going to insert function in each cell to "activate" the formula.  I can't do this for hundreds of rows. How did I break Excel and what can I do to fix it?

best response confirmed by Jan Karel Pieterse (Silver Contributor)
I’d recommend that everyone having thus issue goes to File > Feedback and send a frown, putting your details in the section and start it [Can’t Copy Paste]

Also what version is everyone in who’s having this problem ? File > Account

It will read something like
Semi Annual Channel
Build 1234.567
I have the same issue, have not managed to find the root cause as yet but do have a simple workaround that gets it working again!

Open notepad or an email or probably anything else with some text in it , press Ctrl A, Ctrl C, then Ctrl V. then go back to Excel and Copy and Paste will be working again !

This problem is just because you have 2 instances of EXCEL.EXE and you want to copy paste from one instance to another. You can't copy paste values for example. You can see that from your Start Task Manager. In excel 2010 any workbook opened from explorer was opened from the last application opened. In 365 they try but from my experience sometimes fails to open all of them in only one application.

A solution is to open that excel file using File->Open commands inside your application and not double-clicking an excel file from explorer. I hope this helps.


As a novice user I think I have the same problem. I am trying to copy a range of cells in a column to the adjacent column ( ie next month). I used to be able to do this with one mouse operation - select the cell range then move over to the next column and it would copy that range. Now that doesn't work. It changes the content of each selected cell to the first (top) cell. This is definitely something that has changed or a parameter that I've changed but I don't know what.


Hi Ian, are you doing Right Click Copy then moving and doing Right Click paste or something different?

No, it's one seamless mouse operation. I position the mouse on the bottom right corner of the top cell to be selected then move the mouse down to select the required cells, At the bottom cell I move the mouse over to the adjacent column and it should copy the old contents into the new column. Now it copies the contents of the top cell into all the lower cells and doesn't attempt to copy them into the adjacent column. The cursor displays a bold cross and doesn't change shape when selecting cells or trying to move the cells. It used to display a different cursor during this copy operation.

I think you need to highlight first then drag across from the corner


Highlight Then Drag.gif

Hi, That's essentially what I have been doing. It seems to work now so either you fixed Excel over breakfast or it was my finger trouble....

Let's close this for now and I'll see if it continues to work. I had this same problem last month where it didn't work (as you illustrated) but then it did work later. Hope it's not an intermittent problem - they are the worst kind to fix.

Many thanks, Ian


Add me to the list. Some copy/paste function work,some do not. This started recently.  Specifically I was trying to copy formulas from a range of cells to paste into another range. Some cells had formulas, others only had values. When attempting to 'paste formulas', Excel would only perform a basic 'paste' of all the data in the copy-from range, thus overwriting the values in the target range.  I tested with different files on three separate machines. One desktop and one tablet both running Office 365 desktop versions of Excel 2016, and one other desktop running Excel 2010.  Same problem in all.  Their are two common denominators: All three systems are running windows 10 (two running Pro, one running Home), and all the files tested were last modified using Excel 2016. I've tried all the solutions posted here so far - no joy. I did the feedback to MS are requested. Surely hope this get a solution quickly. Productivity is being killed!!

I was having the same issue as the original post, although after reading the thread I realized I had also lost the ability to drag down from two cells containing 1 and 2 respectively and have Excel complete a series: instead, all the cells in the range now had 1...


Copy&paste didn't work in just one specific workbook, let's call it the "failing workbook". I had a few more open at the same time: copy/paste worked fine in all the others. I could even copy in the failing workbook and paste correctly in another one. It was only in the failing workbook that if I selected a cell (or a range of cells), copied them, and as soon as I clicked on a new cell the dashed lines would disapear and there was nothing left to paste.


Same as the original post, I was able to copy and paste the text content from one cell to another.


I am an occasional Excel user: the only thing that was different between the failing workbook and the rest of them is that it contained macros. I don't fully understand the code, I copied it from a googled example and adapted it to my particular needs. The macros I copied count the number of coloured cells in a range. 


While writing this reply I tried duplicating the file and removing the macro module on the copy.

Copy&paste worked immediately after. 

After this I looked into the macros and saw that I had pasted the following code in the ThisWorkbook option:


Option Explicit


Private Sub Workbook_SheetSelectionChange(ByVal Sh As Object, ByVal Target As Range)

    'Uncomment the next line if you want to make Excel recalculate the ActiveSheet every time the Selection changes
End Sub

So I did comment back the ActiveSheet.Calculate line, and copy&paste worked once again !!


Maybe for folks who are having the issue in any workbook, the problem could be triggered by having a start macro with some command such as the line I showed...


The dragging issue must be another problem because it seemed to happen in all my workbooks, not only in the failing one. However after closing Excel and reopening just the failing workbook, dragging 1,2 to get a series was once again working, both in the failing workbook and in another fresh one I opened. 

I could not get it to fail again...


I hope this helps somebody at Microsoft look into both issues...

I got mine to work... (copying from Excel to Smartsheet (Safari)


I used paste and match style from the Edit Menu when CMD-V would not work...