Can't delete worksheet

Copper Contributor

I'm right-clicking on a sheet, clicking delete and nothing happens.  The sheet is not protected.  I'm not sure what's happening.


I'm running Excel for Office 365 MSO v1902 for Windows.



22 Replies



If the workbook is shared you won't be able to delete sheets. To turn
off sharing, choose Tools>Share Workbook.
On the Editing tab, remove the check mark from 'Allow changes by more
than one user at the same time'
Click OK

Hope that helps

Nabil Mourad

@Mike20878 I was researching this issue for myself. Running excel as admin then opening the book solved the issue for me. There is also a setting to always run the program as admin.

@DougFresh Please can you tell me how I can run Excel as admin. I have the same issue of not being able to delete sheets in Excel.


If you on Windows and have administrative user rights

Win -> Excel -> Run as administrator


@SergeiBaklan Sorry, but this did not make sense to me.  Tested and didn't work.

Hi. This didn't work for me either; at least in my case, having administrative rights makes no difference. This behavior only started after a recent Office 365 update. As there has been no other change in either my Windows 10 system setup or Office 365 or Excel usage patterns, I think this problem likely relates to a bug introduced via the recent update.


I had the same problem. Right-click, Select All Sheets, choose Protect (and it will pop up that something is protected) enter password to Unprotect.  That's what finally worked for me.

@nabilmourad Where is Tools in Excel.. 

This didn't work for me
Simple convert the excel file to CSV Move all the sheets to another workbook and delete? That should do the trick
Disabling sharing worked for me.
I had the same problem, but the sheet was not obviously shared.
By doing SaveAs as a new sheet I was able to delete the unwanted sheets.
In my case the issue may have been caused because the file was in my shared google drive folder - so perhaps some kind of behinds the scenes sharing was in effect?
Review tab -> Unshare Workbook.

Save As features worked for me. I was able to delete the unwanted sheet. 



I have tried all the options others have offered to be able to delete a tab on a sheet, and nothing! 

As someone else mentioned, I only started having this problem after the last Microsoft Office Update!




I figured it out:


Go to the Review tab and click "Protect Workbook". It will have you enter a password to unprotect it. Then you can delete the sheet.

The OP explicitly states: "The sheet is not protected." Are you suggesting that the user protect, and then unprotect the worksheet?
The individual sheet may not be protected but the entire document may still be protected.
I had this same issue tried the various suggestions to no avail. What worked for me was I closed the file then moved the file to my desktop opened it then I could delete the sheet like normal, I saved, closed the file and move it from my desktop back to its original location. I think @grumbled0re may be right and it is shared on one of my shared drives, so moving it to my desktop moved it out of a shared location.