Pop-ups not working in Edge - IE Mode

%3CLINGO-SUB%20id%3D%22lingo-sub-3289865%22%20slang%3D%22en-US%22%3EPop-ups%20not%20working%20in%20Edge%20-%20IE%20Mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3289865%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20preparation%20for%20IE%20Retirement%2C%20We%20pushed%20a%20GP%20update%20for%20Edge%20so%20that%20our%20application%20will%20continue%20to%20function.%20The%20application%20URL%20was%20added%20to%20open%20in%20IE%20compatibility%20mode%20and%20it%20is%20working%20fine%2C%20performing%20different%20functions%20on%20the%20site%20opens%20a%20pop-up%20window.%20The%20pop-ups%20are%20required%20to%20continue%2C%20Our%20problem%20is%20that%20the%20browser%20automatically%20gets%20closed%20%2F%20killed%20whenever%20a%20popup%20window%20opens.%20I%20have%20updated%20Edge%20browser%20settings%20to%20allow%20Pop-Ups%20but%20no%20use.%20Would%20like%20to%20hear%20from%20those%20who%20faced%20the%20problem%20or%20have%20a%20solution%20to%20fix%20the%20issue.%20Thanks%20in%20advance!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EEdge%20Version%20100.0.1185.44%20(Official%20build)%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3416182%22%20slang%3D%22en-US%22%3ERe%3A%20Pop-ups%20not%20working%20in%20Edge%20-%20IE%20Mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3416182%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issue.%20Did%20you%20find%20a%20solution%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3291049%22%20slang%3D%22en-US%22%3ERe%3A%20Pop-ups%20not%20working%20in%20Edge%20-%20IE%20Mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3291049%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E%20Thank%20you%20for%20taking%20a%20quick%20look%20at%20it.%20The%20application%20uses%20Active%20X%20controls.%20APP%20loads%20fine%20in%20Edge%20with%20IE%20mode.%20As%20I%20mentioned%20in%20my%20above%20post%2C%20when%20I%20click%20on%20a%20button%20which%20opens%20a%20pop-up%20window%20is%20not%20working.%20The%20popup%20also%20should%20open%20in%20IE%20mode%20to%20function%20correctly.%20The%20popup%20opens%20in%20a%20small%20window%20and%20then%20everything%20gets%20closed%20automatically.%3CBR%20%2F%3E%3CBR%20%2F%3EAs%20you%20suggested%2C%20I%20will%20email%20MS%20Team%20directly%20(ACHELP%40microsoft.com).%20Thanks!!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3290780%22%20slang%3D%22en-US%22%3ERe%3A%20Pop-ups%20not%20working%20in%20Edge%20-%20IE%20Mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3290780%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1368009%22%20target%3D%22_blank%22%3E%40pnraj76%3C%2FA%3E%26nbsp%3BHello!%26nbsp%3B%20I%20took%20a%20quick%20look%20and%20wasn't%20able%20to%20find%20any%20issues%20that%20might%20be%20causing%20the%20browser%20to%20close.%26nbsp%3B%20In%20the%20IE%20mode%20FAQ%20%2C%20it%20does%20cover%20a%20couple%20of%20questions%20about%20pop%20ups%26nbsp%3B%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode-faq%23why-are-there-rendering-issues-like-text-wrapping-and-content-truncation-when-child-windows-are-running-in-ie-mode-in-microsoft-edge%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode-faq%23why-are-there-rendering-issues-like-text-wrapping-and-content-truncation-when-child-windows-are-running-in-ie-mode-in-microsoft-edge%3C%2FA%3E)%20but%20not%20the%20scenario%20you%20are%20describing.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EHave%20you%20had%20a%20chance%20to%20submit%20Feedback%2Fdiagnostic%20data%20through%20the%20browser%3F%20(%22...%22%20menu%20%26gt%3B%20Help%20and%20feedback%20%26gt%3B%20Send%20feedback).%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EYou%20can%20also%20contact%20the%20App%20Assure%20Team%20if%20you%20have%20compatibility%20issues%20when%20setting%20up%20IE%20mode.%20Either%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Ffasttrack.microsoft.com%2Fdl%2Fdaa%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Erequest%20assistance%3C%2FA%3E%3CSPAN%3E%26nbsp%3Bor%20email%20them%20directly%20(%3C%2FSPAN%3E%3CA%20href%3D%22mailto%3AACHELP%40microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3EACHELP%40microsoft.com%3C%2FA%3E%3CSPAN%3E)%20for%20free%20remediation%20assistance.%26nbsp%3B%20Thanks!%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

In preparation for IE Retirement, We pushed a GP update for Edge so that our application will continue to function. The application URL was added to open in IE compatibility mode and it is working fine, performing different functions on the site opens a pop-up window. The pop-ups are required to continue, Our problem is that the browser automatically gets closed / killed whenever a popup window opens. I have updated Edge browser settings to allow Pop-Ups but no use. Would like to hear from those who faced the problem or have a solution to fix the issue. Thanks in advance!

 

Edge Version 100.0.1185.44 (Official build) (64-bit)

3 Replies

@pnraj76 Hello!  I took a quick look and wasn't able to find any issues that might be causing the browser to close.  In the IE mode FAQ , it does cover a couple of questions about pop ups  (https://docs.microsoft.com/en-us/deployedge/edge-ie-mode-faq#why-are-there-rendering-issues-like-tex...) but not the scenario you are describing.  

 

Have you had a chance to submit Feedback/diagnostic data through the browser? ("..." menu > Help and feedback > Send feedback).  You can also contact the App Assure Team if you have compatibility issues when setting up IE mode. Either request assistance or email them directly (ACHELP@microsoft.com) for free remediation assistance.  Thanks! 

 

-Kelly

@Kelly_Y Thank you for taking a quick look at it. The application uses Active X controls. APP loads fine in Edge with IE mode. As I mentioned in my above post, when I click on a button which opens a pop-up window is not working. The popup also should open in IE mode to function correctly. The popup opens in a small window and then everything gets closed automatically.

As you suggested, I will email MS Team directly (ACHELP@microsoft.com). Thanks!!

I have the same issue. Did you find a solution?