msedge_elf.dll missing

Brass Contributor



Recently, several of our users (including myself) have started getting the following error pop-up, seemingly at random points during the day:


"The program can't start because msedge_elf.dll is missing from your computer. Try reinstalling the program to fix this problem"


The only problem is, it is present in C:\Program Files (x86)\Microsoft\Edge\Application\<version>


This has only started occurring in the past couple of weeks, mostly on our legacy Windows 7 ESU Year 3 estate, which we are fully in the process of retiring. I am aware that the OSD for Edge on Windows 7 is January 15 2023.


Our Edge estate is patched regularly via WSUS, and is fully the X64 version. The latest version we are running is 101.0.1210.39. We also install Edge WebView2, as this is required by software we use, and this is patched via WSUS, to the same version as regular Edge.


I cannot find any information in the EventLog about what application, service or event is triggering this error, can anyone help please?





20 Replies
Have you tried to reinstall the program?
I've also had this issue just a couple of minutes ago. As usual I went online and then I stumbled upon your question. Using the information you provided I copied the file from "C:\Program Files (x86)\Microsoft\Edge\Application\<version>" and paste it in "C:\Windows\System32" and it worked for me.
Missing dll files usually can be fixed by downloading/moving the file and put it in the System32 folder or the application folder. I think for this case the program did not check for the file in the application folder.
That may work as a "workaround", but it doesn't explain why this has suddenly started occurring?
We have a similar problem since May 6. We are using Edge 101.0.1210.53 on Win10 20H2 and Win10 21H2.
In our case, the problem occurs when a new configuration file for Ivanti Application Control is installed. The error message can be acknowledged (sometimes several messages appear) and then everything works normally again.
The problem is difficult to reproduce, on some machines the error does not occur at all, on other machines the error occurs only sometimes when a new configuration is installed.
Is there any new information about the cause of the error?

Hello @tgoldschrafe @jdseymour1978 and anyone else on the thread!  If you are encountering the msedge_elf.dll error, please reach out to Support ( They will be able to gather logs and help investigate your specific case.  Thanks! 



@jdseymour1978 @tgoldschrafe @Zmegatrolls @Parker93x Hi Everyone!  The team is currently investigating and trying to find the root cause.  In the meantime, they do not recommend moving msedge_elf.dll into the System32 folder.  


We will follow up once the team has any updates.  Thanks! 





Any update on this issue ? 

@Kris_Boeckx @jdseymour1978 @tgoldschrafe @Zmegatrolls @Parker93x Thanks for your patience!  We do have some updates about this issue.  Our developers have investigated and found that the issue is caused by multiple different third-party software vendors who are injecting running threads into the MS Edge process.  


We did make a change in MS Edge Canary Channel (v104.0.1287.0), adding the following environment variable will work-around the issue:




Please be aware that using this workaround does slow down the MS Edge launch.  



We also have Ivanti Application Control (aka AppSense) and received a report of this error.

@communityusermatthew @tgoldschrafe Hello!  If you have identified the third-party software vendor that is causing the issue, you can reach out to them directly and let them know about the issue.  Also, you can ask them to avoid injecting running threads into the MS Edge processes, which would help reduce these types of issues.  Thanks! 




Ivanti released an article for this issue. We used the second workaround (Add msedge.exe to DriverHookEx).

That's not practical if it's your antivirus software doing the injection.
Hi - can you confirm if this is the current advised solution. I have recently encountered this problem as well.

Also is this a global environment variable I need to add? - I will need to instruct my IT support team to do this; so want to be clear what I'm asking for.

@TimP_MM Hi! If it is Ivanti that is causing the issue, it might help to review this article they published: 

Deploying an Application Control Config Returns msedge_elf.dll Not Found ( (This article was mentioned by another user)



Thanks - but I don't think I have any Ivanti on my computer...


I also encountered this error and found the possible quick fix on this issue:
1. Go to Window Settings > Apps > Installed Apps (alternatively use "Windows Key + I" then click Apps > Installed Apps ) , then find Microsoft Edge (showing the version/build no.) in the Apps List.
2. On the right of App List for Microsoft Edge click the 3 dots "..." , then Modify (click Yes to the prompt to allow changes) then click Repair button. This will start repair the installation files for Microsoft Edge. After successfully repaired it should be able to launch the Edge browser without the error.