Cannot sign-in to Edge with Microsoft Account

This thread has been locked for new comments by a moderator, if you have a new similar issue then please start a new thread.
Occasional Visitor

I have this error. I reinstall edge some times but the same issue.

The Microsoft Edge team has been notified of this issue. Please try again later. Error code: -2147023584



17 Replies

@dqtiep Thanks for reaching out and letting us know. We're sorry to see that!


@Avi Vaid, do you have any insight into this or know who might?


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@dqtiep this error is a rare scenario and the exact description is "A specified logon session does not exist. It may already have been terminated." Our experts in this area tell us that this error code could indicate many things, e.g., user jumping from one domain to another, etc. We will discuss internally and get back to you with more questions. Thanks for your patience!

@Avi Vaid Interestingly I see the exact same issue happening. I have 3 computers in my home, 2 personal, one work issued. All on the same wireless network. All upgraded to the new Chromium Edge. My two personal computers are logged into Edge with my Hotmail account and syncing with no issues. My work laptop can log into my Hotmail for email, but won't let Edge login using that credential to sync with my other computers. I see the same error mentioned above. 


This has been an issue since I first tried to switch to Edge two weeks ago. 

Got the same issue for weeks. Cannot create a second profile in Edge on my work laptop. No problem to sign in with my work account though. Also no problem to sign in with my private account on my private systems.


Like others, I'm unable to sign in with my personal microsoft account on a work computer that's already logged in with a "work" profile. Maybe those who have work profiles through Microsoft can't also have a personal profile signed in? That seems to be the common them from folks on this thread.

@jlindine @dqtiep @juliantb @Dean Misenhimer  Thanks for the details!


Per the Enterprise Identity team: we’d love to look into this further, and it would really help us troubleshoot if you’re open to submitting feedback and diagnostic data. Depending on your comfort level and device permissions, you could securely submit that via one of the following ways:


  1. Simply send logs via the Office Sign-In and Authentication diagnostics via the download here: (It captures relevant AAD/MSA/WAM/NGC info and does a screen recording for you)
  2. Submit detailed feedback through the browser along with a screen recording, diagnostic data, and attaching a screenshot of your logs under Security Privacy/Windows Authentication
  3. Follow this process ( and choosing the category "Security and Privacy" and the subcategory of "Windows Authentication.”

Once you do this, we will engage to fix the issue you're running into. However, if submitting any of the above isn’t possible or is outside of your comfort zone, then can you try re-domain joining to fix?


Please let me know if you have any questions! And if you want to be sure the team sees your feedback as quickly as possible, feel free to comment (or send me a private message) about with method you used, so they can keep an eye out.


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Option 1 completed from me.

@Deleted Having the same problem, it came and went but now it seems to be here to stay.  3 machines on the same network but only this one is affected.  I've started following your guides on submitting diagnostics, but in the meantime if there is any further info I'd be grateful to hear it.


Feedback app won't let me report a problem, just hangs with circle


Many thanks



I also cannot sign-in with Microsoft Account while my work account is automatically signed in and syncing.

I have just set BrowserSignin=1 and NonRemovableProfileEnabled=1 in my test environment.


When trying to sign a second profile i select to sign-in with Microsoft Account after a short waiting i get the error 0x800704ec.

are there any news on that?

@Johannes Goerlich Thank you for your patience as we've looked into this! We've revised our documentation and have some suggestions to share.


For the error: 0x800704ec, the team suggests looking into the following policies on your machine, as they might be the root of the issue.


MDM Policies:

  • Accounts/AllowMicrosoftAccountConnection: 
  • Accounts/AllowMicrosoftAccountSignInAssistant: 

Group Policies:


Hopefully that helps! If not, just let me know and we can do some further troubleshooting.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Avi Vaid Not that rare, since im also having this problem.

We do have the same scenario here, but with a different error code:





I would like to know where I can find the log-file for this action, if any?



@Thomascaa I've been getting this for weeks, and have yet a different error code:



@DocJShan Did yousolve this issue already? we have the same issue. what we did find was; if we take the server out of the local domain it works, but when we join the domain again it fails again as well.

hopefully you did find a solution.



Hi all,
I had an issue where I couldn't login to Edge, saying "Error Code 20, 17, 0".
I resolved through:

  1. Close all instances of Edge with Task Manager
  2. Delete %LOCALAPPDATA%\Microsoft\Edge\User Data
my account has been terminated for no reason, what did I do wrong?