Bug in Edge Policy Handling: This policy is blocked - its value will be ignored.

Frequent Contributor

Starting with Edge Dev 85.0.538.0 (and even in current Dev 85.0.552.1 as well as Canary 85.0.558.0) the Policies like HomepageLocation, DefaultSearchProvider, RestoreOnStartUpURLs etc... which need an MDM-Enrolled or AD-Joined Device don't work any more! 


This Bug affects all Policies which are documented as "This policy is available only on Windows instances that are joined to a Microsoft Active Directory domain or Windows 10 Pro or Enterprise instances enrolled for device management." => All other Policies still work as expected. 


They are now ignored and edge://policy shows "Error: This policy is blocked - its value will be ignored.


2020-06-29 17_59_23-Clipboard.png


In previous Releases like Dev 85.0.531.1 or Beta 84.0.522.20 as well as current Stable 83.0.478.56 these Policies still work (tested on the same MDM managed Win10 Enterprise Device).


Test was done using Microsoft Intune / Microsoft Endpoint Manager Admin Center with an AzureAD joined device. There is nothing wrong with MDM-Configuration, Stable and Beta-Release of Edge still works as expected, only Dev+Can are affected!

24 Replies

@josh_bodner @Deleted I'd like to give some feedback on how I feel when giving the Edge-Team feedback.


1. I tried to report this bug several times via the "Send feedback" Button in Edge Dev => just got an auto-answer email response, but nothing else

2. I tried to report this bug to @josh_bodner as a reply in his Dev channel update to 85.0.538.0 is live, because no change regarding this changed behavior or bug was listed. Just got a reply to use the "Send Feedback" button which I already did.

3. I opened a paid Microsoft Premier Support Ticket to report this. Got the answer that Edge Dev is outside the Support-Scope and I cannot report this bug, I have to wait this Bug coming to production-stable release

4. Wrote this Techcommunity-Message, @josh_bodner reacted by mentioning @Deleted but nothing else happened.


What I would expect is, that you acknowledge you are aware of this bug and are working on it. But currently I feel totally ignored on all channels, even the paid ones. 

@Gunnar Haslinger Sorry for all the running around, the main reason I wanted to make sure we at least had one piece of feedback from you (which I wasn't aware you had already done when I replied on the release notes) is because we also get a bunch of logs from your machine when you send feedback.  Those logs are very valuable for diagnosing issues, but unfortunately the in-product feedback system also isn't immediate when it comes to responding to customers, since it's dependent on engineers to update the issue in our work database once they're actually working on the issue.  


We're definitely aware of the issue thanks to you reporting it, but since not all issues get fixed immediately, that's probably why you never got a response from the feedback system.  As for responses here, this isn't necessarily the best place to get live help since that's not what this forum is designed for.  Your best bet would be to open a support ticket with our dedicated browser support agents.  You can do that from ... > Help and feedback > Help.  I'll also ask our team if there's anything we can do to get Premier support to transfer Edge Insider users over to our agents since that's definitely not a good experience to just be told that Insiders aren't supported.  

@Gunnar Haslinger, sorry about your experience and please use this direct link to file a support request.  Josh's suggestion also works and this might be even quicker :)  

Thanks for your response @Joon Chang@josh_bodner.

I once more used "Send Feedback" to send an MDMDiagReport attached as well as opened an Microsoft-Edge-Support-Request.


I hope this Bug gets fixed before Edge Dev reaches Beta-State.

Edited: To update you, it looks like one of our experienced Support agents has received and responded to your ticket, and is having our devs investigate this.




@Gunnar Haslinger Thank you for bringing this to our attention, Gunnar. Our mission here on the Insider forums is to provide a direct connection between users and the dev teams, while ensuring that our MSFT Edge Insiders feel heard and valued. So we're sorry to hear this wasn't your experience. (This has prompted an internal discussion about how we can improve this experience.)


To provide some context on our process: there are Microsoft eyes on the forum almost every single business day. However, due to the volume of high-quality feedback, it may be a few days before we can address each reported issue, as we typically do a preliminary investigation before responding.  The forums are also generally more geared towards community discussions and troubleshooting between other professionals. Contrastingly, Insiders can get special 1:1 support from our highly trained Microsoft Edge support team (@Joon Chang and @josh_bodner linked it above.) While this team is better equipped to answer questions quickly, there isn't the community-based aspect that this forum offers.


However, we truly value our users' feedback and expertise; if you're seeing unexpected behavior in the browser, we definitely do want to hear about it, no matter the medium! Since each of our feedback avenues has different uses and advantages, it really helps our devs when Insiders follow in your footsteps with a personal outreach coupled with data submissions.


Thanks again for letting us know about this, and we'll let you know if/when we have insights from the team to share. I'll make sure our Insider Support team keeps an eye out for your request.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge


@Gunnar Haslinger It looks like our agent followed-up with an update. In case anyone else has a similar question, I wanted to share it here too.


Great news: a fix is underway, and should be deployed shortly! Thanks again for your persistence and help with getting this addressed. If you have any more questions about this or other policies, please let us know.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

I can confirm the Policy Handling Bug "This policy is blocked" ... is fixed in Edge Canary 86.0.580.0

But the bug is still there  in current Edge Dev 85.0.564.8 which seems to be promoted to Beta soon.


So please fix it in v85 too before it hits Beta-State.

@Gunnar Haslinger Good news: I just got confirmation from our Enterprise team that yes, the fix should be coming in the next v85 builds!


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

Thanks @Deleted


I can confirm, it is fixed and working now as expected in Edge Dev 85.0.564.13

@Gunnar Haslinger Excellent! Thanks again for your help in calling this to our attention, and please let us know if you see anything else.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Gunnar Haslinger 


This bug is now present in the productionversion of Edge version 85.0.564.68 (Official build) (64-bit)

I tested the same policy in the Beta, Dev an Canary. There the is even worse as more settings are blocked. The picture i have uploaded is from the productionversion.


Schermafbeelding 2020-10-04 om 18.23.17_censored.jpg

@Ronald Meer 


I just checked Version 85.0.564.68 (stable), Version 86.0.622.31 (Beta), Version 87.0.654.0 (Dev) and all seems to be fine. I'm not using the policy AutoOpenFileTypes which I can see as "blocked" on your Screenshot, but I'm using "RestoreOnStartUp" with Value 4 too, and it is working as expected, no "policy is blocked" error.


As my Screenshot in the first posting of this thread shows, I'm using all Policies as "Mandatory". Your Screenshot shows, you are using "Recommended" Policies, but I just tried to switch over to "Recommended" instead of "Mandatory" policies and it still works as expected, see screenshot below:


2020-10-05 08_09_41-Clipboard.png

@Gunnar Haslinger 


Hi checked the same settings on a another device. There all the policysettings have the status ok.
Same setup of windows 10 same version edge.

Only difference is that the device on which all policies are ok is a laptop. The device where some settings have failed is parallels virtual machine on my Macbook

@Ronald Meer are you aware of, that these Policies are only accepted when the Machine is MDM-Managed or AD-Joined?

@Gunnar Haslinger 


Both devices are managed with Intune and azure ad joined.

@Gunnar Haslinger 

Having the same problem here. you mentioned it's fixed in Edge 86 but I'm experiencing it in Edge 87!

Why this policy is producing error? Configure new tab page URL - Microsoft Tech Community


@HotCakeX cannot confirm your experience.


Just tested:

Stable Version 86.0.622.48

Beta Version 86.0.622.43

Dev Version 87.0.664.11


All three work like expected, no "policy is blocked" error at my test-machine.