Sites loading unreliable

Super Contributor

Microsoft sites and a few others will fail to load, show a 'Cant reach this page sign'. I have to refresh it a few times and then it will load, along with other tabs with Microsoft sites open, but only for a few seconds. This isn't happening in Firefox or Spartan edge, does anyone know why its happening?cant reach page.png

21 Replies
You're using the Canary?
Try with extensions off: edge://extensions/

@cjc2112 I wonder if this is the same iFrame issue I'm dealing with. That's the same message we get trying to access LogMeIn from Edge Chromium. 

@braddn @cjc2112

Thought I would give it a try, see if result matched... it did not. Was done in both Dev & Canary.



Try to Log in

@HotCakeX All extensions off, still happening, but (forgot to mention earlier) it only happens when connected to the school wifi.

@braddn I don't know, the site is blocked on my wifi, so I can't tell if it is.


@cjc2112 wrote:

@HotCakeX All extensions off, still happening, but (forgot to mention earlier) it only happens when connected to the school wifi.

Well there you have it, you already know the answer ;)

Use a VPN (could be even an extension) or proxy (lots of free ones)


UWP Edge (Classic Edge) does not use proxy configurations so whatever your school is using to block connections, it might not be applying to the Edge classic.


Firefox supports its own proxy settings and can easily ignore system proxy configurations

@HotCakeX The LogMeIn error doesn't occur until we are in the LogMeIn Central Console and you try to remote on to another computer. When I inspect the source it looks to me like when the iFrame is called for the remote session it then errors out. 


I can get to the LMI homepage, login, see the list of computers in our account. We just can't remote on to them. The other site having issues is the Dell SonicWall firewall admin web site. That is definitely an iFrame issue. 

@HotCakeX Then how come chrome also loads the sites with no problem? How come edge is the only browser to have problems?


Please use this method to send Microsoft a rich feedback and error report






sign out of Logmein or clear cookies, close all tabs, start recording and recreate the problem, let it recording everything and then press stop.


now write the complete description of the problem but Don't hit the send just yet.


close the tab again,


go to this page: edge://net-export/


press "Start Logging to Disk"


then press "Start Logging to Disk"


follow the instructions and then do the same thing you did again, recreate the problem and let it record all the network issues that happens. attach that file to your feedback




and now hit send


@cjc2112 wrote:

@HotCakeX Then how come chrome also loads the sites with no problem? How come edge is the only browser to have problems?

Good questions..

Try this, go to edge://net-internals/#sockets

go to proxy, DNS, SOCKETS, one by one and clear/delete all caches and restart browser. if it won't fix it then it may be just a bug with Edge


you could try netsh int ip reset on powershell/CMD with admin rights too but don't think you can do it on school computers


you could also check if they are controlling your Edge: edge://management/

@HotCakeX I tried doing what you suggested, no change. They aren't controlling Edge either.

Which channel are you on ?

Hey everyone! Thanks so much for bringing this up. This is something we are aware of. I have no news to share about it right now, but once I do I will post back here to follow up. :)


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge

@cjc2112 @braddn Hey, guys! I wanted to follow up here and find out if you can get me specific website links for the websites you receive this error on. One we know of is, and we know of the complaints around LogMeIn which requires you to have logged in to the website. If I could get all URLs for where you see this, or have seen this, it will be of great assistance. More information on the Dell SonicWall access would be great, too!


I really appreciate any help you both can provide!


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge

@braddn @HotCakeX -- The issue with LogMeIn and is a known problem, a bug for which is filed upstream: You can workaround the issue by closing all instances and restarting the browser:


Start > Run (or Win+R)

   msedge.exe --disable-features=PostQuantumCECPQ2


I would be very interested to learn whether this workaround also fixes the "Dell SonicWall firewall admin website" (which I assume is not on a public URL).

(As to "why Edge fails and Chrome doesn't?"-- Chrome Beta and Dev and Canary will fail. Chrome Stable does not yet have the change that the site cannot handle.)


@cjc2112 : I would also be interested in learning whether this workaround has any impact on your scenarios. If so, it's likely that your network administrator is using some sort of HTTPS filtering software that is failing to handle the larger handshake sent by the PostQuantum experiment. 

@MissyQ I'll try to get some error info tomorrow at school.

@ericlaw I talked to Edge support. For me the LogMeIn and SonicWall admin page is a known bug in the Dev build however we downloaded the Beta build and both sites are working. So I'm going to switch over to the Beta build for a bit more stability. 

@braddn Thanks for letting us know. I tried Microsoft sites that were having problems and the bug is fixed in beta.