Cisco WebEx Breaks Edge Dev

Frequent Visitor

When Edge Dev starts a popup dialog in the lower right corner says "Cisco Webex Content Sharing has crashed.  Select this balloon to reload the extension."  The page content displays "This page is having a problem"


Selecting does noting except make the dialog disappear and re-appear. 


Edge is non-functional - Can't get to settings or extensions.  Even the "smiley face" feedback does not work.  Extensions won't load (page dispays, but show "This page is having a problem".

13 Replies

Hi @Ward Durossette - Thanks for the needed details. I have filed this for you.


Can you not load Microsoft Edge at all now with this extension? Curious if this is the case and if you are able to load Microsoft Edge via without extensions per below. I get mixed results on using this switch in different builds, let me know if this helps.


MSEDGE.EXE --disable-extensions





@DarrenMH I'm getting the same error.  Removing / reinstalling EDGE DEV has no effect.  


Tried your fix and all it does is grey out my extensions menu.


@DarrenMH What is the status.? This problem propagated today also to the Beta version. What you proposed does not work and also removing and reinstalling does not solve the issue. Now both my DEV and BETA versions are blocked... How can I fix this?

I can only assume that many business users use the Webex extesion and are blocked too...

Thanks for your help.


@Rudi66 LastPass just did this to me as Edge BETA and DEV completely broken and cant get to any sites.


I was going to try and figure this out...I just gave up...back to Chrome I go...this EDGE Chromium is excellent up until it breaks...then it's unfixable.


I give up.



Same problem here. Edge BETA gives the Cisco Webex Extension has crashed message and is unusable.

Had the same problem with Edge DEV previously and uninstalled it. In both cases cannot get to Settings or Extensions or any other webpage. "This page is having a problem" message no matter what option or page I try to navigate to.

Restarting/Rebooting has no effect. 


@Ward Durossette Can you confirm if this works in Chrome? We would like to establish if this is a Edge Specific issue or an extension specific issue. 


@CraigChubbuck Could you pls confirm the behaviour in Chrome? We need to know if this is an extension specific issue or browser specific?


Also I need 2 more things:

1. What does this extension help you do?

2. Steps to use this extension as expected or as working in Chrome. 




The extension is loaded when you try and use Cisco WebEx conferencing for the first time.


Extension is working in Chrome, was loaded from Chrome extension store.


If only I could manually delete the extensions directory so that EDGE would no longer load this, I could perhaps simply avoid it...for now, I cannot even load ANYTHING in EDGE even the page to change settings.


@CraigChubbuck Thanks Craig. 


Here is the link I found to install the extension. It says, a plugin is required to be installed for this extension to work.


Could you tell me if the plugin downloaded for you? If it downloaded and installed, then It seems the plugin is not compatible with Edge. (This is the plugin you need: )

Also pls check if there are any enterprise policies breaking this extension. Share a screenshot of edge://policy like the one below:

I am able to repro the issue. We are investigating and will keep you posted as we know more. 







I'm not sure exactly why, but I just tried Edge Beta and it seems to be working now.  the latest update made it so I could actually launch Edge and I'm using it now for this post!!






I am having the same issue. Reinstalling the edge or launching without extension does not fixes the issue. Please fix. Version of Edge is : 79.0.300.0




I just downloaded the Edge Beta and it works fine. Version Please fix the Edge Canary. (79.0.300.0). Edge Canary gives the message


This page is having a problem
Try coming back to it later.
You could also:
• Open a new tab
• Refresh this page