Getting Error code: 0x5000004 for RDC from MacBook

Getting Error code: 0x5000004 for RDC from MacBook



 Jan 17 2022
3 Comments (3 New)
Tell us more

We couldn't connect to the Remote Desktop Gateway because the connection to the remote PC failed. If this keeps happening, contact your network administrator for assistance.


Error code: 0x5000004

Status changed to: Tell us more

Hi @UmeshDeshpande 

Can you please provide more detail on how this error occurred? The most informative method would be providing a video to the email alias, footage from a phone camera or screen capture works perfectly fine, that demonstrates your experience in the app and reproduces the error (if the video file is too large to email please upload it to this Dropbox and specify this in your email). An alternative if you cannot take a video would be providing detailed steps on how the error occurs and how it can be reproduced.


Furthermore, please provide as much additional detail as possible in the email to help our engineers reproduce the error including:

  • If relevant, the number of users within your organization experiencing this issue.
  • If relevant, the error code produced by this issue and any related crash logs.
  • What hardware are you (for example: MacBook Pro 13-inch, M1, 2020)
  • What type of operating system you are running (for example: macOS Monterey (version 12)
  • What type of resource are you remotely connecting to (for example: a Workspace in Azure Virtual Desktop, a PC running Windows Server 2016)
  • If relevant, how your Remote Desktop client is configured (for example: Is Drive redirection enabled, are you using external keyboard)


This will help us provide support as quickly as possible. Thanks!

Copper Contributor

I just had this error.


My problem was the end user plugged in a wifi adapter and rebooted the computer. On restart the wifi connected to an open wifi network and the firewall activated as a public network blocking all incoming connections. I disabled the wifi and restarted and the connection then worked fine.


Check the firewall on the local machine to make sure it is allowing incoming connections.

Copper Contributor

I am having this same issue.  Ii have a new MacBook Pro M2 running 14.2.1 (23C71).  I downloaded the Microsoft Remote Desktop client from the Mac App Store and I am unable to connect to any servers at my work.  If I use my Windows 10 or my Windwos 11 machine, I am able to connect without any issues.  However connecting using the sae settings and same credentials on my MacBook Pro it gives me the error mentioned above.
I am the IT Manager and my SysAdmin and My Service Tech are able to connect using the same credentials and connecting to the same server on Windwos machines.  It is only my Mac that is not connecting.

I have called Apple Support and they said I need to contact Microsoft as it is a 3rd party application running on a Mac.

I need to get into my work machines to work!  How do I do this?  

PS I did give Microsoft Remote Desktop Full Disk permissions, as I did see in one thread about this error.
I did reboot and it is still giving the same error message.

@js351 Answer to your questions:
I am the only Mac user at my work, so I am the only one having this issue.
Error code is:  0x5000004

MacBook Pro 13" M2 2022
macOS 14.2.1 (23C71) running Microsoft Remote Desktop Version 10.9.5 (2179)
I am trying to connect to a physical machine running Windows Server 2016
I am using the default configurations, nothing special.

I am the iT Manager and my sysadmins are stumped too.