Word Mail Merge Suddenly Broken

Copper Contributor

1st wondering if an update has wreaked havoc. I usually turn off auto updates, but hadn't done so. Anyone know if there was an update in the past week, and if so, how I can roll back?


Using Windows 10 Professional, Office 365 Business.


For decades I've been exporting from a database to an ASCII delimited file as the data source. I run a Word merge and it's worked extremely well.


I've now spent 4 hours trying to figure out why Word all of a sudden chokes trying to open that exported data source file. 


As per the screen cap below, it has run every field in the data source together into one. You can see "PubFore" does exist in the huge text string:










I've tried changing the delimiters to every possibility. Though it doesn't sound like it should work, for so many years the export was comma delimited separating fields. The database also added quote marks (ASCII 34). So between each field it has:




FWIW, records are separated by ASCII 13 + ASCII 10 (carriage return + line feed).


Not exaggerating when I say this has worked since the early 90's. 


I've tried changing the data source to strictly TAB delimiters, to strictly quotation marks, to strictly commas, etc. Though it can always be converted to a table, it just won't work in the mail merge.


The header hasn't changed. Just the field names separated by commas.


If I try opening the data source I get this File Conversion error:





... and it doesn't correctly guess the number of columns etc. anymore when I try to convert text to table.


I've already blown a deadline, don't want it to get worse, and I'm soooooo tired, as John would sing, so any guidance would be tremendously appreciated.


Thanks and best regards,

9 Replies

Something else happening now... triggering the mail merge with VBA which opens the merge form/template now causes error that Word can't find the data source even though it is in the directory listed in the dialog box. Any ideas why it would say it's not?



And now this:




No idea. I'm looking right at the data records with data in them.

Can you upload a copy of the data source so that we can investigate the issue.
Same issue for me also I think after updating to office 365 - 2202 Build 14931.20132 no longer supporting email merge. I am unable to send HTML format email merge from word. And gives me same encoding pop up error while sending in plain text format.
Can you upload a copy of the data source so that we can investigate the issue.

@Doug_Robbins_Word_MVP  @ashuwith


I'm not receiving notifications of responses to my posts from this website. Apologies for the delay.


I fixed it by gradually replacing everything from backups (i.e. Data Source, Merge Header docs, etc.). I think things got fixed when I replaced Normal.dotm with an earlier version.


I have asked this before a couple of times, but it does 'seem' like things get broken shortly after updating Office apps. I've never received a response as to how to confirm dates of said updates or how to roll back to earlier versions.


Of course, I'd very much like to know if upgrades are modifying (corrupting) my Normal.dotm or any other FILE. I think MS would like to know as well and if it's the case, I hope they stop doing it!!!!!!

I do not think that the updating of Office would have anything to do with the issue.

However, without a copy of the files that you are using, it is not possible to provide any assistance.
Thanks for your time, Doug.

Do you happen to know of a way looking up the dates of the most recent updates?