Server Manager problem: Online - Data retrieval failures occurred

Occasional Contributor

Hello,
I'm using Windows Server 2022 and I have this problem: data retrieval on Server Manager.
Is there a fix for this issue?

Obs:
- this is a test lab
- all servers are domain members
- I'm connecting on all servers with the domain Administrator account.
- tested with both Firewall on and off
- do NOT recommend this workaround: delete/rename the registry keys HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels\xxx

Thank you.

12 Replies
I have had the same issue like yours for several days:
2-member nodes in a cluster have the same problem once restarting each.
I have fixed it just very simple by changing a register keyword like this:[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels\Microsoft-Windows-Kernel-IoTrace/Diagnostic]
"Enabled=dword:1"
modify to
"Enabled=dword:0"
That is ok to solve this problem perfectly!
regards!

@MartinikWe have the same issue. Did you find a better solution than changing the registry value mentioned below?

No. I'm still waiting for an answer from the Microsoft team, if they have one. :)

@Martinik 

 

Thank you. This option works for me.

I had modify the registry from "Enabled=dword:1"
modify to
"Enabled=dword:0"

but every time i reboot the server it change back to 1. 

backup then you can delete the "enabled" key and reboot.

We have exactly the same problem. Server 2022 in 2-node Failover Cluster.
We use Intel(R) Ethernet Converged Network Adapter X710 10 GB in SET mode dedicated only for Hyper-V and Intel(R) PLAN EM 1GB T OCP, two ports in Teaming for only Cluster network. There is also an additional error with Microsoft-Windows-Kernel-IoTrace/Diagnostic when opening the event viewer - administrative events see picture.2022_event.JPG

At the beginning, we didn't have any problems, but when testing live migration of virtual machines and higher network load, one of our nodes crashed and after that, errors occurred, but everything is still working properly now for several month.
By changing the registry the errors can be removed but I don't know if that's the right way?

@Martinik 

 

Hello Martinik,

 

The error shown above is a server manager issue. Thus it gave us an error "data retrieval failures occurred" while retrieving the data from the server manager.

 

Here are the steps you can follow to overcome the data retrieval failure occurred issue,

 

Open the command prompt with administrator access and execute the below command:

 

cd C:\Windows\System32\wbem\Autorecover

 

Now, /f %s in ('dir /b *.mof *.mfl') do mofcomp %s

 

When the above command completes, you can start the Server Manager and start adding roles and features again.

 

If this doesn't work, you can check the below fixes,

 

The error can also be caused when the system cannot find the specified file.

 

HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > then, Windows > CurrentVersion > WINEVT > Channels > Microsoft-Windows-DxpTaskRingtone > Analytic

"ChannelAccess-> "O:BAG:SYD:(A;;0xf0007;;;SY)(A;;0x7;;;BA A;;0x3;;;BO)(A;;0x5;;;SO)(A;;0x1;;;IU > (A;;0x3;;;SU)(A;;0x1;;;S-1-5-3)(A;;0x2;;;S-1-5-33)(A;;0x1;;;S-1-5-32-573)

Enabled = dword:00000000

Isolation= dword:00000001

"OwningPublisher"="{3df0c2c1-5a04-4966-9790-df6ef0ccde9c}"

Type -> dword > 00000002

 

You should compare the above to other entries. Looking at the Isolation and Type of other entries, this should not even show up in the event log. You must edit the key's name and ensure that it disappears from the event log. Then, try changing the name back and check if gone or persists. 

 

Lastly, refresh the Server Manager and check if it became green, but if you see red, then back up the key and delete it. Thus, with the key gone, the server manager also refreshes without any error, and all of my manageability icons will get green without giving any error

 

I hope the above solution will work for you to fix the data retrieval failure error.

 

-----------------

Regards,

Austin_M

@Austin_M 

 

Hi, when I write /f %s in ('dir /b *.mof *.mfl') do mofcomp %s in C:\Windows\System32\wbem\Autorecover it shows an error :(

 

@Miguel77 

 

I guess you have to write for /f %s in ('dir /b *.mof *.mfl') do mofcomp %s

@Martinik Amigo yo tenia ese mismo problema con Windows Server 2016 y me di cuenta que el problema era de hora y fecha que no estaban bien

@Martinik Did you solved this problem? I have the same error on Windows Server 2022. I don't want to change the register HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels\Microsoft-Windows-Kernel-IoTrace/Diagnostic.