Building a Windows Server Lab with an Intel NUC

%3CLINGO-SUB%20id%3D%22lingo-sub-291275%22%20slang%3D%22en-US%22%3EBuilding%20a%20Windows%20Server%20Lab%20with%20an%20Intel%20NUC%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-291275%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EWith%20the%20%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fwww.thomasmaurer.ch%2F2018%2F10%2Fwindows-server-2019-released%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Erelease%20of%20Windows%20Server%202019%3C%2FA%3E%3CSPAN%3E%2C%20which%20includes%20a%20ton%20of%20Hybrid%20Cloud%20integration%20features%2C%20it%20was%20time%20to%20build%20a%20new%20lab%20environment.%20The%20plan%20is%20to%20create%20a%20lab%20and%20demo%20environment%20for%20my%20presentations%20and%20workshops.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3ECheck%20out%20more%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Fwww.thomasmaurer.ch%2F2018%2F11%2Fwindows-server-lab-intel-nuc%2F%22%20target%3D%22_self%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.thomasmaurer.ch%2F2018%2F11%2Fwindows-server-lab-intel-nuc%2F%3C%2FA%3E%3CFONT%3E%3CBR%20%2F%3E%3C%2FFONT%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-291275%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECompute%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EContainers%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHyper-V%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EManagement%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EStorage%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439196%22%20slang%3D%22en-US%22%3ERe%3A%20Building%20a%20Windows%20Server%20Lab%20with%20an%20Intel%20NUC%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439196%22%20slang%3D%22en-US%22%3E%3CP%20data-unlink%3D%22true%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2310%22%20target%3D%22_blank%22%3E%40Thomas%20Maurer%3C%2FA%3EHello.%26nbsp%3B%20It%20may%20be%20off%20topic%20and%20not%20sure%20the%20best%20place%20to%20post%20this%20and%20I%20apologize.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20just%20wanted%20to%20add%20that%20I%20have%20discovered%20why%20the%20RAID%20config%20kept%20failing%2C%20for%20those%20who%20are%20using%204gen%20NUCs%20as%20servers!%26nbsp%3B%20Basically%20the%20%3CSPAN%20class%3D%22uiOutputText%22%3E%3CA%20href%3D%22https%3A%2F%2Fark.intel.com%2Fcontent%2Fwww%2Fus%2Fen%2Fark%2Fproducts%2F81164%2Fintel-nuc-kit-d54250wykh.html%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fark.intel.com%2Fcontent%2Fwww%2Fus%2Fen%2Fark%2Fproducts%2F81164%2Fintel-nuc-kit-d54250wykh.html%3C%2FA%3E%20model%20at%20this%20link.%3CBR%20%2F%3E%3CBR%20%2F%3EIt%20seems%20that%20the%20Secondary%20slot%20for%20a%20SATA%202.5%22%20SSD%20or%20HDD%20would%20%22fall%20out%22%20of%20the%20RAID%20array%20on%20reboot.%26nbsp%3B%20And%20other%20times%20reappear!%26nbsp%3B%20Very%20annoying!%20Since%20my%204%20NUCs%20were%20in%20warranty%20at%20the%20time%20I%20opened%20a%20case%20with%20Intel.%26nbsp%3B%20They%20came%20to%20the%20conclusion%20that%20the%20SATA%20edge%20connector%20board%20was%20defective%20and%20they%20sent%20me%20new%20version%20ones%20to%20swap%20in.%26nbsp%3B%20This%20seemed%20to%20work%20for%20awhile....%3CBR%20%2F%3E%3CBR%20%2F%3ENow%2C%20we%20flash%20forward%20to%202020.%26nbsp%3B%20I%20am%20redoing%20one%20of%20those%20servers%20and%20lo%20and%20behold%2C%20RAID%20problems%20re-surfaced!%26nbsp%3B%20I%20was%20like%20%22WTH!%22%26nbsp%3B%20I%20swapped%20back%20each%20of%20the%20old%20SATA%20boards%20for%20sh*ts%20and%20grins%2C%20but%20no%20change!%26nbsp%3B%20Im%20like%2C%20this%20is%20one%20bad%20Greek%20Tragedy!%3CBR%20%2F%3E%3CBR%20%2F%3ETHEN!%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22uiOutputText%22%3EI%20tried%20swapping%20the%20power%20and%20SATA%20cabling%20from%20another%20NUC%20Im%20using%20as%20a%20bedroom%20media%20server%2C%20AHCI%20mode%2C%20non-RAID.%26nbsp%3B%20And%20BOOM!%26nbsp%3B%20RAID%20issues%20vanished!%26nbsp%3B%20It%20seems%20that%20I%20have%20finally%20found%20the%20true%20cause%20of%20the%20intermittent%20RAID%20issue%2C%20with%20the%202.5%22%20drive%20disappearing%20and%20reappearing%20again!%26nbsp%3B%20POOR%20QUALITY%20CABLING!%26nbsp%3B%20At%20least%20with%20my%20tests.%26nbsp%3B%20And%20fortunately%20the%205gen%20and%20on%20seem%20to%20have%20addressed%20this%20with%20better%20quality%20cabling%20from%203rd%20party%20vendors.%3CBR%20%2F%3E%3CBR%20%2F%3ESo%20my%20advice%20for%20those%20who%20are%20seeing%20this%20weird%20malady%20on%204gen%20NUCs%2C%20try%20swapping%20the%20cabling%20between%20NUCs%2C%20using%20any%20cabling%20from%20NUCs%20you%20will%20not%20make%20a%20RAID.%26nbsp%3B%20And%20see!%26nbsp%3B%20It%20worked%20for%20me%20and%20I%20am%20basking%20in%20gloatatious%20sunlight%20lol.%3CBR%20%2F%3E%3CBR%20%2F%3E5%20years%20on%20and%20my%20NUCs%20are%20running%20like%20tops%2C%20all%20forms%20of%20MS%20technology%2C%20rock-solid.%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22uiOutputText%22%3E-Speak-%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

With the release of Windows Server 2019, which includes a ton of Hybrid Cloud integration features, it was time to build a new lab environment. The plan is to create a lab and demo environment for my presentations and workshops.

 

Check out more here: https://www.thomasmaurer.ch/2018/11/windows-server-lab-intel-nuc/

1 Reply
Highlighted

@Thomas MaurerHello.  It may be off topic and not sure the best place to post this and I apologize.

I just wanted to add that I have discovered why the RAID config kept failing, for those who are using 4gen NUCs as servers!  Basically the https://ark.intel.com/content/www/us/en/ark/products/81164/intel-nuc-kit-d54250wykh.html model at this link.

It seems that the Secondary slot for a SATA 2.5" SSD or HDD would "fall out" of the RAID array on reboot.  And other times reappear!  Very annoying! Since my 4 NUCs were in warranty at the time I opened a case with Intel.  They came to the conclusion that the SATA edge connector board was defective and they sent me new version ones to swap in.  This seemed to work for awhile....

Now, we flash forward to 2020.  I am redoing one of those servers and lo and behold, RAID problems re-surfaced!  I was like "WTH!"  I swapped back each of the old SATA boards for sh*ts and grins, but no change!  Im like, this is one bad Greek Tragedy!

THEN!

I tried swapping the power and SATA cabling from another NUC Im using as a bedroom media server, AHCI mode, non-RAID.  And BOOM!  RAID issues vanished!  It seems that I have finally found the true cause of the intermittent RAID issue, with the 2.5" drive disappearing and reappearing again!  POOR QUALITY CABLING!  At least with my tests.  And fortunately the 5gen and on seem to have addressed this with better quality cabling from 3rd party vendors.

So my advice for those who are seeing this weird malady on 4gen NUCs, try swapping the cabling between NUCs, using any cabling from NUCs you will not make a RAID.  And see!  It worked for me and I am basking in gloatatious sunlight lol.

5 years on and my NUCs are running like tops, all forms of MS technology, rock-solid.

 

-Speak-