Windows Insider update fails

Copper Contributor


during the last few weeks I have had the same windows Insider update downloaded and my laptop tried to install and failed that same update every time.

The download succeeds, and the update is being installed, while my laptop is running and I am working.

Then when rebooting, the update tries and updates, but never gets to 30%.  In fact, I have the impression it never gets to the point that it shows a Windows update screen with a percentage.  What I get to see, is, with the BIOS background and the progression bar spinning, the spinning is hanging at a certain point in time.  I have to hard reboot at that time, when the update tries again and fails again (I suppose the same failure, the screen shows the same).  At that time I hard reboot once more, and the update then tries to recover, at which it seems to succeed. (I get a windows login and can get to work again).


This same update happened I think 5 to 10 times the last few weeks.  Don't remember the exact name, but today it says Windows 11 Insider Preview 10.0.22621.160 (ni_release), which is a next revision of the update, I think.  I will try to install this update now, but I think it will fail again...


I don't know where to find logs for the past updates, so I don't know what else to give you for information.  Waiting for your answer, I will try this new update.  When you could tell me what info to send, so you can find more information, I can look for that.

31 Replies
Firstly, since you are in the Windows Insider build make sure use Feedback Hub app and report this issue.
In case you are using Dev channel, try switch to Beta channel and install the latest update and if it works, then switch back to Dev channel.

@Reza_Ameri Thank you for your swift reply.

This support page was given to me by a microsoft professional.  I executed what I was told.

As I will use the Feedback hub next time, as per your request.

I am on beta channel currently.

The update I talked about has not finished installation yet (before first reboot) (94% in Windows update page now)

As a feedback on Feedback Hub: I filled some feedback in it, I think a few years ago - the feedback hub does not say, and *never* got any reply. I guess that's why I do not really run to that app... I'm sorry to say I'm still unsure that will bring me something except more lost time...
OK, update failed again.
I watched the progress now: Windows update installs while I am working and requests a reboot. I reboot, and Windows finishes its initial installation.
Then it reboots, and comes back up to 12%. Then reboots again and never comes back up. The progress indicator hangs and needs a hard reboot. Then the update tries to recover updating. It hangs again and needs another hard reboot. Then Windows tries to recover, and I am typing this in Windows again...

Entered the same in Feedback hub, but it does not support so many characters, so the last two paragraphs could not be entered, and I could only fill half the story. What's the use then ? Then it proposes to record something. But the problem occurs after rebooting, so it can never record that, I suppose. So I opted for no recording. Feedback entered. I wonder if I get a useful answer on that feedback or any answer for that matter, ever...

So I am on beta channel, not on dev channel.

What information can I provide for you in order to solve this ever reoccurring update problem ?

Hi @GeneralSan 

I totally agree with you!

Information about errors in the Insider Program is automatically transmitted to Microsoft and analyzed by AI in real time!

" As a feedback on Feedback Hub: I filled some feedback in it, I think a few years ago - the feedback hub does not say, and *never* got any reply. I guess that's why I do not really run to that app... I'm sorry to say I'm still unsure that will bring me something except more lost time..."


Please analyze this step:

"Reset your device.
Use Reset this PC to reset your device, which will reinstall Windows on the same build you're currently on."

Troubleshooting - Windows Insider Program | Microsoft Docs


@A1 Thx for your suggestion. Yes, I know that will work fine.
If this were a home pc, I would have enough time to do that too.
But it’s a work pc. It takes me 2 days to install client’s software for sso, install and configure all my other software, and get my things back up and running. And I don’t have this time, I’m afraid. For the moment it’s running fine, though I might miss some updates, which for work is fine.
I was hoping for a less painful solution.

Then again, restarting every few days for the same update, which takes at least half an hour, and takes a few manual hard reboots, also takes my time of course…


I understand, and the update troubleshooter?
A little risky - if it is a computer to work in the Beta channel.
You have installed some third-party program with the highest permissions - this prevents you from closing all processes and undoing changes, delete the cache, pause the update

Microsoft might not share your response for every feedback, but they will read your feedbacks.
Try open start and search for cmd or command prompt and right click and run it as administrator and then type the following command:

sfc /scannow

Press enter and let it runs.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.
You may try performing Clean Boot and run Windows Update and see if the problem persists?
Have a look at:
I reported this issue via Feedback hub ~3 weeks ago: still persisting
Thank you for sharing the link, please who are facing the same issue upvote the post.
Have you tried the Clean Boot?
What was the result?

@Reza_Ameri Thx for following up.  I didn't have time to get around to it yet.  I will try.

Welcome, Clean Boot won't remove any data and it just start your system with essentials services to troubleshoot the issue and you may select to run Windows normally.
Please try it and tell us about the result.


So I did the clean boot, which bumped me into the login screen.

The login screen did not accept my correct password, nor it lets me enter a pin code. (I have stored my password in a password manager, so I know I'm entering the correct one)

Restart keeps booting into the clean boot.

I ended up with an unusable computer...  So the result ? Not so good, I'd say... :(

Hi @GeneralSan 

If you have not fixed it yet - then if there will be a login screen again, then enter the entire password of the Microsoft account (the system should start correctly)

write if it works?

The entire password of the microsoft account was my only option (pin code was not supported), and windows did not accept my correctly entered password, as I tried to convey in my last post...
Strange me after logging in with a Microsoft account I have never had a problem in such cases (try again)