Windows insider preview 22621.1 (ni_release)

Copper Contributor

I can download the update but it will not install and I get error code 0x80070002 and the suggestion to try again which I havew done to no avail.

25 Replies


This version is only for the Beta channel – is your switch on Beta?

yes it is
Try disabling updates and resume downloading the next day, sometimes the computer needs to install new components, which is why it does not update
Thank you Andrzej1 I will try that
Hi I have a similar situation... Download ok, install "ok", but when the computer restarts the OS come back to version 10.0.22000.593 with no message, error, alert...
I found a solution to this. For me I had this error as well 0x80070002 which I could not update Windows 11. In my log files I found out that the western digital drivers were causing this error. I removed the driver and this fixed it for me.

My log file showed this with the error code C:\Windows\System32\DriverStore\FileRepository\wdcsam.inf_amd64_7ce69fc8798d6116\wdcsam.inf
Try to run Windows Update troubleshooter from Settings app > System > Troubleshoot > Other troubleshooters. See if it helps!
thank you
of course
how can you find the error?
I found mine in log files. Go to your system and then the windows folder. You will see one called logs. Look at all the files you see. There will be .xml files and .log files. Only look at these and not the .etl. They are useless for this.

For me mine was in a .xml file. See if in the logs you can find the same error of 0x80070002.


Ethan, I found this: "Failed to import driver package 'C:\Windows\System32\DriverStore\FileRepository\realtekapo.inf_amd64_8cbe839b568570ce\realtekapo.inf'" in "C:\Windows\Logs\SetupDiag\setupdiagresults.xml.


Could you expand on how to do this, for a new update: "I removed the driver and this fixed it for me"

Thank you, Mike

Is fixed or no? Did your pc get latest update?

@mhendric Nevermind.  I figured out what worked for me. I was getting access errors when I tried to delete/alter the files, in question.  Reminder for who needs it: 1.) Make sure your login is in the local admins group. 2.) On the folder (files) in question, Right-click -Properties-Security-Advanced. 3.) Change Owner from SYSTEM to your Account (next, next, Finish). 4.) If not still open...Right-click - Properties - Security - Edit - Add your account - and give Full rights (next, next, Finish)..   That SHOULD give you the ability to delete the offending folder - and Retry the Update.   Anyway - I hope this helps someone - it worked for me!  Thanks again, Ethan!

Yessir! I'm caught up now - thanks to your tip! -Mike
Glad it worked! Hope you backed up the drivers you removed. You may need them still just in case something stops working right. It should be 100% good to go though

Hi @mhendric 

Thank you for posting, changing permissions and taking ownership of the object in the test versions is also used in my case and it really works on many computers, but it requires experience.,

However, I suggest great caution.

Best regards

100% Correct. Even though I always backup before deleting stuff - I didn't mention it. Glad that Ethan caught it. Thanks -M
Try installing using the ISO, this worked for me. I created a bootable USB using Rufus and clicked into the files within the USB where I clicked setup.exe.
Here is the link and instructions: