[Windows 11] Hover on taskbar apps don't get preview when open multiple windows of the same app

New Contributor

Is this a glitch or features? I have the problem since the first Windows 11 Insider Preview (Dev Channel, Build 22000.51). But it seems haven't be fixed yet. My current OS build is 22000.176 (Beta Channel).


Hover on apps with one windows of the same app:



Hover on apps with multiple windows of the same app:



What it suppose to look like when hover on apps with multiple windows of the same app:



Does anyone has this problem too?


38 Replies
I have the same issue on OS Build 22000.318
Can the issue come from updating from Windows 10 without fresh reinstall?
Have you guys try to update to Build 22000.346? I don't think this related to the upgrade from Win10.
Yes, I'm actually on Build 22000.348. It is fixed on my Laptop, but not my PC, both upgraded from Windows 10.
Make sure open the Feedback Hub app and report this issue on the affected device.
A reset of Windows did the trick. Fixed for me
Thank you for the update and glad the problem fixed.
I have the same issue. The preview works fine under one window but after the second or more I no longer see the previews.
I just purchased a laptop that came with Windows 11 installed. I see that this issue still exists. Any updates on how to enable to hover feature yet?
Like I mentioned earlier, try run Windows Update and download and install all updates and restart your PC.
In case problem persist, report it using the Feedback Hub app.


This computer is new, has all updates. Your suggestion doesn't work.

Where is the "feedback hub"?

Even for new devices, when you check the Windows Update , there might be new updates.
Have you checked the Windows Update?
You may open start and search for "Feedback" and you will see the Feedback Hub app.
Ok, just to humor you, I did the most recent updates AGAIN that were available. No change.
In this case, you have to report this issue using the Feedback Hub app.


So I here's how to resolve the issue:

Search for "View Advanced System Settings" in the windows search and open settings then: 

Under Advanced tab -> Performance -> Settings 

Uncheck and check "Enable Peek".

It will reset the setting and "Peek" will start working.

Thanks for weighing in but Enable Peek was already checked. I did as you said and still no change. I even changed the setting to be Custom instead of letting Windows choose. Still no change.
This is really frustrating.

I've just bought a new laptop with win11 installed and although I'm seeing previews when hovering over the taskbar, I'm finding it nigh on impossible to click on the preview to bring the window to the fore: the preview disappears as I move the mouse from the taskbar to the preview. On win11, there's a vertical gap between the taskbar and the preview: on win10, there wasn't so there was no opportunity for focus to be lost.
FWIW I've enabled focus follows mouse like I have had since winxp days if that has any bearing.

I have that too if I have multiple instances of the same program, i.e., 2 word documents, 2 PDFs, 2 different Chrome browsers, etc... And I recently had another update and still no changes.
I really hope this gets sorted soon else I'll have to "downgrade" to windows 10 (if I can) or install a third party solution.
I've reported that via the feedback mechanism. I cannot understand how such a fundamental issue has escaped Microsoft's engineers.