Win11 Build 22494 won't update to 22504 no error codes present

Copper Contributor

I am attempting to update my build version from 22494 which it is currently to 22504. I downloaded and installed it, when I restart it starts to apply it and restarts multiple times, which is fine but, at ~48% it restarts and then says "Undoing all changes applied to your computer" and just stops applying it. I then have to re-download, install, and repeat the steps once more to have the same message pop up.


There are no error codes given, and it doesn't say to activate the Flight which, I have already done through command prompt.

7 Replies

@M_K_K Same here... trying to upgrade from 10.0.22489.1000 ... gets to 48%, sits there for a few minutes then reverts!

Try open start and search for feedback and open the Feedback Hub app and report this issue.
You may investigate log files to find out what causing this issue, take a look at:
Thanks, Reza. Yes, looked at the log files you pointed me to via that link and it said it was the Antivirus that halted the upgrade. Uninstalled it and the upgrade worked perfectly. Thank you!
PS: I have updated for a few years now without the need to remove the AV yet this time I had to, MS changed something!
Thank you for the update.
Yes, sometimes the Anti-Malware product would cause the issue.
In many cases, you have to update the Anti-Malware product for it to work or you may report it to the Anti-Malware vendor , so they investigate and fix this issue.
I'm not sure if I am looking at the log files wrong or what but, the setupact.log shows no errors and is full of mostly audio migrations, setuperr.log is blank, Setupmem.dmp doesn't exist, and neither does

When I looked at the update history, I was able to find an error code "0xc1900101" which, when I looked that up, it stated that there was either a driver that was not updated or a third party antivirus was causing an issue (Similar to MuchHeart).

I uninstalled the only antivirus that I have, and went through and ensured every driver was up-to-date which, still proved futile. I was hoping the log files would direct me to a more specific problem.
Well, this required some technical skills and experience and sometimes you could find files right away or you will need to review and look for it. In any case, glad the problem have been solved.
I apologize if there was confusion; the initial person that replied to you saying that it helped fix their problem was someone else.

My problem (the OP) has not been rectified as of yet and am having difficulty with navigating the log files. If you have no further advice, that's okay. I appreciate the help you have given thus far either way, helped me learn a little bit more :)

I attempted again to uninstall my anti-virus program last night and installed an automatic device updater to ensure everything was as up to date as it could be but, neither of those helped. I have also tried restarting Windows update services through service.msc and through CMD - both proved futile.

The log files remained unchanged as far as my previous issues with them