W10-1903 UNC path failing 0x80070043

Copper Contributor

I can no longer access network shares through unc paths \\server\share I get the 0x80070043 "Network name cannot be found" error.


I suspect that this is related to the removal of Homegroups? but surely it was not intended to break basic UNC functionality, or am I missing something?

97 Replies


it seems it may be specific to Dell Compellent Fluidity, so probably some sort of issue with their smb implementation.
It works fine with my home Synology Nas, and MS fileservers


But it has worked fine on previous win 10 versions

@kurgan Any luck figuring this out? Having the same problem over here with our Dell EMC UNITY SAN and it's killing me. 

Make sure they are connected on the same network. In network sharing settings, enable 128 Bit encryption and allow network discovery. There are 7 services related to network sharing in services.msc. Also, both systems must run on the same build of Windows 10.



I think you're missing a part of this. We're talking about a DELL EMC box not running Windows. It's running Linux but SMB has worked without issue on all prior Windows 10 versions. Things broke with 1903

Just downloaded and installed the Windows 10 Enterprise 1903 release from MSDN to test and this issue is still present. On latest build 18362.53. Our company's files shares are mostly hosted from Dell EMC/Unity. I have been able to confirm that Windows Server file shares and Nutanix Files shares are unaffected. Hopefully they will get this fixed by the RTM next month.


Just wanted to add that we also have problems using SMB with 1903 and our 2 Unity 400 (latest code).


This is a big issue for us but I find it strange that I haven't found anything on the Internet about this except here.

@itkpli Same problem also here with Build 19h1 and Dell compellent FluidFS. no poblem with windows servers. does anyone else can test on a linux machine with standard samba ? 

@SybuxWe've now filed a support case with Dell/EMC about this.

We'll see what they say about it.


@itkpliI just subscribed to this post. I just wiped and reloaded my 1903 machine thinking I had screwed it up. Good to know I'm not alone. I also cannot access EMC Unity shares.


I've created this problem report in the feedback hub if you wish to upvote it:




@itkpliwhat did Dell say?


Did anyone fix this issue yet? we are on the same boat with Dell Unity, we will also open a case with Dell. Just want to know if anyone has any insights. 

@ThiagoCardosoThe response from Dell/EMC so far has been to tell us to contact Microsoft.


While it might be an issue with Windows 10 1903 it's still something Dell/EMC should be concerned about because it will hurt their customers. I'll update here if I get any more info.

If you'll shoot me the case number, I'll include it in a ticket that I create with them.

We are having the same issues. We are trying to access shares on Dell EMC FluidFS connected to compellent storage. I have raised a support call with Dell EMC and the response was

"The purpose of the preview releases (which are expected to have bugs) and the Microsoft Insider Program is to identify any potential bugs and report back to Microsoft so they can address them accordingly (sometimes they advise registry edits etc as temporary workarounds until the full release).

Have you tried addressing it with Microsoft yet so they can investigate further for you"

Hopefully Microsoft will look into the problem. 



Wow. Nice of Dell to explain the program to us!  Lucky for me, I have a WebEx this morning with one of their Engineers that seems to have an idea to at least try.  Fingers crossed; I'll report back.

Good news, everyone!


Dell/EMC has a work around for this issue. By setting the SMB Max Protocol version to 3.0.2 (down from 3.1.1) I am able to access shares again. Please start a Dell/EMC support ticket and quote SR 14282798.


Kudos to engineer Harsha Vardan for providing the work around!

@dwatsonI got the same info yesterday as well from a local EMC representative who had looked at your SR and it's good that they have a workaround.


However there are quite a lot of improvements in 3.1.1 compared to 3.02.

More info: What’s new in SMB 3.1.1 in the Windows Server 2016 Technical Preview 2



Agreed on all counts. At least we're not dead in the water, though, while we wait for a fix.

@dwatson Presumably this fix is for Unity?

We still have the same problem with FluidFS and Dell have told us it is Microsoft's problem.

Has anybody found a fix for FluidFS?

1 best response

Accepted Solutions
best response confirmed by NedPyle (Microsoft)

Hi everyone. We got access to the Dell KB and see the issue in Dell/EMCs 'Unity' CIFS implementation.


From the DELL EMC KB attached to thread (below), the Unity SMB Server implementation is failing on the "SMB2_NETNAME_CONTEXT" and "SMB2_COMPRESSION_CAPABILITIES" we added in 1903. These were changes designed to add some new capabilities to SMB; we make some variant of these at most OS releases. If an SMB/CIFS server doesn't recognize capabilities, it should ignore them, not fail. Otherwise Dell would have to update their SMB implementation every time we released a new SMB capability that didn't also include a protocol dialect revision (like "SMB 3.1.2"), forever and ever. 


Error Messages in the Unity c4_safe_ktrace.log:

sade:SMB: 3:[nas_serverx] Unrecognized SMB2 negotiate context type 0003
sade:SMB: 3:[nas_serverx] Unrecognized SMB2 negotiate context type 0003


SMB client sends the compression context before the netname context, so the server encounters the compression context first. The Unity server would probably encounter the same problem with the netname context. Instead of failing when their SMB Server version doesn't support more advanced capabilities, it should be ignoring those capabilities. This is what Windows and other 3rd party SMB products do.


@kurgan thanks for opening this techcommunity item, I'm sorry I didn't see it until now.


Ned Pyle | Principal Program Manager, MS | @nerdpyle on twitter

View solution in original post