SOLVED

Killer wireless driver error (Code 10 and Code 43)

Copper Contributor

After the last update for Windows 11 insider (Home). The driver for the wireless card stopped working. There is already a guide on the issue on Intel's boards, but it is not working either. So i think the issue is with the Windows.

 

The card: Killer(R) Wireless-AC 1550i Wireless Network Adapter (9560NGW) 160MHz
 

What didn't work: 

  1. Restoring the system
  2. Reinstalling the drivers (normal reinstall and fresh reinstall)
  3. Rolling back to earlier drivers and deleting drivers from DriverStore in System32
  4. Following Intel's "guide" (Link)

Appreciate the help, thanks in advance.

53 Replies

Finally I got it fixed.

after many many times I’ve tried to fix it, finally the problem’s solved. 
I replaced killer wifi adapter with another one and everything is done. 
No more wifi problem :grinning_face_with_sweat::grinning_face_with_sweat::grinning_face_with_sweat:

i have a dell inspiron 14 5000 2 in 1 and this problem has also happened to me today i have tried to uninstall the driver several times to no avail with the driver going back to the original state of not working again. WiFi is my only option to connect to the internet since my 2-1 does not have a Ethernet connection. please help???

@davo5003 

 

From Device Manager try removing the device and uninstalling the drivers, then shutdown your laptop. Do not reboot or restart. Shut it down then power it back on. When it powers on the device should be back and working. This has fixed the problem more than once for me. Can’t explain why, but it has. Good luck!

I have this problem already since January I think: sometimes I can work without does and than the problem returns, very frustrating. I have an Lenovo idea pad 3 15iil05 and yes that **bleep** Intel Wireless AC9560 gives me the error code 43. I removed them, I downloaded the latest drivers at Lenovo, but it doesn 't solve the problem:-(.

Anyone?

@Fabian_nl I have the exact same laptop. This problem has happened to me multiple times I have brought it to Best Buy twice now to get it fixed. But the problem always comes back. It might be 2 weeks or 6 weeks, but it never fails to fail me.

None of these "fixes" permanently fix the problem. I have a different adapter "Intel Wireless AC 9462 Adapter" but I've seen similar problems on many Wifi adapters and everything points back to Microsoft and Windows Updates. The problem has been ongoing since June. Various fixes work from 1 day to 2 weeks and then I login and No WiFi.

Fixes tried, none of which permanently resolves the issue:
run cmd prompt as admin:
netsh winsock reset
and
netsh int ip reset

this used to work then stopped working.
Next, Uninstall the Driver in Device Manager, shutdown and unplug for at least 30 minutes.
also tried going into the BIOS, installing all the updated drivers for my system from Dell, etc, etc.

The problem ALWAYS comes back. No Wifi and error Code 43.

Seeing the tons of users all having similar issues is extremely maddening.

@O513-Epsilon dealing with the same issue I have the same driver and I'm also on an MSI machine.

 

It's driving me nuts. 

 

Fine for days then stops every 10 seconds.

 

I've contacted Intel so if I get an update I'll respond again so hopefully others can be helped. 

 

It's so exhausting! 

@HeyImLeila Please update once you get the response from Intel.

Hey Leila, I have actually encountered this issue once again. I though I had it fixed but apparently not. Very maddening indeed.

My next step in this is to upgrade to windows 11 and hope that works, if it doesn’t I might revert back but idk.

If that doesn’t work then I’m guessing this is going to be a hardware issue.

Also you can try to clear your registry.

https://www.lifewire.com/how-to-delete-the-upperfilters-and-lowerfilters-registry-values-2619222

If none of those don’t work please come back with any helpful information intel man has.

I have 2 sons with identical laptops. One laptop has this problem. Upgrading to Windows 11 did not fix it. Reinstalling Windows 10 did not fix it.

The only reliable temporary fix we have found is to open device manager, remove the device, then shutdown the laptop (not reboot. Shutdown.) When the laptop powers on the driver has been reinstalled and works. No need to leave it powered down for any amount of time.

 

The problem comes back every 2-3 weeks, and we repeat this process. I keep monitoring this post hoping someone will find a permanent fix, but until then I hope this temporary fix will help people who are in a bind. 

I tried this option but just as a restart, not a shutdown. I will attempt to do this and see if it works. Restarting only led to a possible temporary 5 minute fix.

Thanks

@yclian I'm using an Alienware 13R3, updating to the latest Killer drivers didn't solve my problem. Removing it entirely (incl. the drivers) and restarting the machine magically solved it.

 

 

MY MAN!!!! 100% WORKED... I messed around with this dang thing for the last 3 hours and this works. 

 

"search ->device manager-> network adapters -> killer wireless adapter *right click* -> uninstall AND delete local driver files check box when prompted -> restart computer -> it works" 

 

bazinga!

@TechGuy246 

Your step by step works well for me ! Thanks !

Today the problem re-appeared again and nothing helped :-(.
Where to get this newest driver?
My problem is okay with your solution. All the others above didn't work. Thanks!!
How did you remove the drivers? I know you can go into Device Manager ->Network Adapters -> Killer Network Adapter then right click then uninstall but is there anything else you did?

I have a ACER Predator PH 315 with the 1550i killer chip and I've uninstalled the driver before, but like some others on this thread, it only worked temporarily, and the wifi went out randomly less than a day later.
This step by step worked! We'll see how long before it breaks again but for now the frustration is gone! :)

@OussD I have recently just got this fixed in my Lenovo y740 laptop. Similar problem, lots of connectivity issues, code 10 with the driver. Turns out the WiFi card was not properly secured to its position from the factory and had jostled loose after a year or so of use. Simply reseating it to its correct position was enough to cause it to work again. Hope this helps others looking for a solution!

Thanks  that did the trick after installing critical alien updast to firmware and other 

@TechGuy246