Green Screen after Builder update. volsnap.sys

Occasional Visitor
Im on my other computer right now, the windows machine cant get to the desktop. after an update of the insider build it gives me the GSOD says the insider ran into a problem and need to restart. page fault in nonpage area. problem with volsnap.sys
19 Replies
I see the same thing on 17025, it starts with 'Preparing Automatic Repair' and goes to the GSOD. Same message as Matt. Interestigly it seems to alternate between a GSOD and a GSOD. I'm on a Dell OptiPlex 990. F8 during boot doesn't get me to the Recovery options page.

Hello Kerry,


F8 for Windows 10 has been deprecated (though there are instructions on the net - it is easier to get to w/ new instructions). To get to the new boot menu hold this shift button when clicking on the power icon and 'restart'. Keep the shift key held down and before long you'll see a spankin new menu for you. You can do this at the log in or post log in.


As far as the issue - I get the exact same thing. Person who replied punted and said it was a graphics driver issue. Here is my reply in response - I hope this helps:





My current driver for Nvidia is up to date: version 388.00 at this writing which is as up to date as you can get for a 960. Graphic driver updates are no longer the dominant issue for Windows since the decision to include them within their update scheme. Your tech article's example is slightly different from mine (see attached).  As I wrote earlier, this is, per the green screen, likely because of volsnap.sys. I believe this file has more to do with software/hardware connection with the USB or storage. I also have no other pending updates except for build 17025.


The temporary fix for now for insiders if seeing this issue and their graphic driver is up to date as mine is:

1) As SOON as you get your regular windows wallpaper back up post boot try to hit Windows + X

(You are working on the clock here and need to get this done before the next update and the inevitable crash happens - so do this quickly!)


2) Select Windows PowerShell Admin


3) You'll unnervingly have to wait for an 'okay' for the shell to run. As soon as it comes up let the OS know that PowerShell Admin is indeed, 'okay.' 

4) Run this command ASAP from the PowerShell Admin:
net stop wuauserv

This should stop the errant update service.


5) Quickly go to Settings / Update and Security. If it was in between initializing and downloading you may have to repeat step 4 because it'll just rerun wuauserv. If you have a button that says Retry, DON'T press it - the OS has temporarily given up on installing updates (this is a good thing for us). Feel free to use your machine for an unlimited time until you have to reboot and restart this entire process again.


These steps aren't the best, but at least you can use your computer for longer than 10 minutes at a time. Obviously it is a good idea to every once in a while try the update so you get the best working OS and security, but an OS isn't considered working properly if it is resetting within 10 minutes.


Hopefully Microsoft will be taking this situation seriously and working with insiders such as myself and others as to the cause to prevent this issue from reaching the common update ring.


Thank you,


Rob Milliken

Thanks for the great detailed response Rob!  Unfortunately this doesn't help me.  Neither the Shift-key nor Windows-X get any response during the eternal reboot loop.  My next step is to make and boot from a WinPE disk.




Hi Kerry,


Follow this thread for a fix: if you haven't seen it before.


As an aside, I wouldn't give up on that how to get to that special boot menu I described earlier, it is good to know about. I'll try to be more succinct: press on the power icon. You should get restart/sleep/hibernate/go to jail do not collect... etc... (Okay, maybe not that last.) Hold down the shift button and while doing so select restart but keep the shift held down while doing so. It should restart, but boot to a special menu.


Hope it all works out!

Rob Milliken

When I tried this, it just keeps saying access denied - any clues?


This has kept crashing on me since Thursday when it updated automatically and I can't use my laptop which is causing major issues for me

I just fixed this issue by copying the volsnap.sys from a different Insider Preview system to the affected system.  The date stamp on the good file is (10/21/2017).


Since the laptop would not boot past the endless GSOD/BSOD, I first mirrored the HDD to another system and tried to copy the file over.  The file is owned by the trusted installer and will not allow the copy, gets the Access Denied like you mentioned.  I created a Generic Boot Key using WinPE and booted stand-alone.  There are several boot utilities (but be careful of the ones you choose).  So basically, boot the affected system from a boot key/thumb drive that allows access to the files and the copy should work.


Other factors you might have to get past are drive encryption, etc.  Once past that, my system works now.  Ready for the next update......

If you have desktop:I found a temporary fix to the problem if you have a usb to sata adapter put you hard drive sata cable into it then power on your desktop and then plug the usb to your laptop(if you have a laptop)and a window should show up on the laptop it should say scan and if when a window shows up don't change any setting and leave it run when it's finished plug out the sata and turn off your computer/desktop the put the sata cable it in your desktop and turn on your desktop and that's it. Hope it helps.



You think you have OWNERSHIP of your own files? HA. Seriously, MS does this so someone doesn't touch files they shouldn't and lock themselves out of the machine. Therefore the instructions I am about to give should contain some caution and come with no warranty. Definitely BACK UP your volsnap.sys to something else before replacing it. Read here how to take ownership of this file: ... I find this is best done from the command line with administration privs. I did it without any special boot up into Window, just log in and get it done before your machine resets. I personally did this then copied an old volsnap.sys file (from same machine but a September volsnap in a windows.old directory) with Windows Explorer. Then I manually requested the update. I did honestly felt about as nervous as a person who is facing a firing squad because I tried this before with a different volsnap.sys from a laptop and it didn't work. Low and behold, about an hour later after starting the update, I was indeed updated and no more resets. I hope this works for you and ends up saving you time instead of wasting it. If you have an encrypted disk you may have to do more digging to get this to work (see original solution under Michelle's post on announcement of the 17025 release for more details).

Thank you,

Rob Milliken

Thanks Jim but I'm stuck on using my iPhone and iPad until I can somehow get this fixed! Trying to do what you suggest - thanks btw - is not something I'm able to achieve, I guess I have to wait for another update I guess....

Thanks for the feedback and suggestions Rob, but as I've just mentioned elsewhere, I'm operating from my iPhone and iPhone until I get another update from Insider Programme to fix the laptop. It seems that the Laptop is running really slow, so by the time it settles down to actually use, it goes Green Screen again! So, unless the next update fixes it, I guess the laptop is dead!!



My feeling is that the update process in your current build is broken, therefore, the next update probably won't fix your issue since you can't update to it. This holds true at least to the situation I was in.

So, taking this a step at a time. When you first turn on your laptop are you getting to the log in screen? It is usually where the time of day shows up and you can enter a password. Also the power options, restart/sleep/hibernate are available here. You shouldn't get a green screen if you stop here (don't enter a password yet). If you do have an issue before you enter a password, there may be another issue at work. Anyway, can you get to this screen?


Thank you,

Rob Milliken

It's weird Rob as when it switched back, it went through the build screen and it was like a brand new laptop as I'd lost everything on my desktop! Then it crashed again and did it twice more! Now, I've had four restarts where I lost my WiFi and finally I had to hard wired it to the router to get it working but it still kept crashing. I've the Wifi back and now have the login screen back too



Okay, long term, it might be a good idea to do a hd and RAM check, but since you have the log in screen, press the power icon on the log in display, you should get restart, hibernate, shut down, etc... Hold down shift WHILE selecting restart and keep the shift key held down until you get an optional menu (it may restart once to do this). Under advanced (I think - you might have to hunt down the structure a bit) there is a place where you can go to command line only to supercede any countdown to update. After locating an old volsnap.sys, *back up* your current volsnap and use this: to take ownership of the file. Replace your volsnap.sys and cross your fingers. I hope this works for you and helps others. There of course, is more than one way to do this, but this is one route that may work best for you. If you have your disk encrypted, you might have more of a challenge to get this done (see Michelle's original post and subsequent thread on the release of build 17025 for details on how to get past that as well.).

 EDIT ADD: volsnap is located under /windows/system32/drivers


Thank you,


Rob Milliken

Same issue. Contacted support. Told me to boot from a USB. I hope it works

My update is that the solution from worked for me.  I copied in a volsnap.sys from another machine using a USB drive, my PC finally booted and I was able to upgrade to 17025 and it seems to be working fine.  


Thanks for everyone's help

Hi ?Rob,


I'm running a HP 250 G4 Notebook PC with a CPU 3700 1.60 GHz  processor and 4Gb of RAM. I've tried for last few hours what you have suggested but trying the shift key is not working. This is a real pain as this is now a whole of this issue and I can't keep working from my iPhone and iPad as the Microsoft office App's are not great! This is now the third laptop that Microsoft have damaged and I'm getting really annoyed at their lack of support and customer service on issues like this. Not everyone has two machines or more lying around to have one as a back up in case issues like this arise. So, I'm at a lost on how to fix this laptop

Hi Ian

I was where you are up until yesterday.  I think you have to follow the instructions to replace the 17017 version of volsnap.sys with an older one.  Since, like me, you can't get out of the reboot loop, you'll have to boot from a DVD or USB drive.  Then find another version and replace it.  As I said, this worked for me.  If you don't have the resources, you'll have to get help.  This situation shows why you only use Insider builds on a spare machine and not your main one.


Good luck,




I agree with Kerry. Hopefully you have a BIOS that'll boot to a USB or DVD drive and can go that route. As I mentioned the other day, there is (thankfully) more than one way to do this. Do you have access to an alternate volsnap.sys so you can get it replaced? I would attach mine that fixed my situation (and anyone can feel free to do an anti-virus scan) but I am not sure if that violates some Windows copyright.


Sorry about the shift/restart issue - not sure why it doesn't work on your laptop. If you want to pursue this option again if the usb/DVD Windows 10 bootup doesn't help see this article:


I hope you get it working soon!


Thank you,


Rob Milliken