Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Windows Security and Enter Network Credentials Pop up. I am denied access to my own network.

Copper Contributor



Hopefully some one here can help me with this major conundrum.  I have tried all of the recommended fixes I could find - at other Microsoft sites and through many Google hits, but none of them have worked. 


I am and have been running Windows 10 Pro 64 bit OS with no problems - and have not upgraded to version 1703 yet, but some time last week... I could no longer connect to any devices on my home network from Explorer on my PC.


My first failure was trying to connect to any Shares on my WDMYCLOUDEX2 and then experiencing an instantaneous denial/no access trying to access two oth computers on my LAN.popupbox.jpg



When I try to connect to any shares on my WD MyCloud EX2 NAS, or to any other computer on my LAN, including a MacBook Pro and an iMac - I am immediately shown the grey box above which already has "Access Is Denied" in red letters at the bottom - as soon as the box appears.

So, I am - in effect, already denied access before I can even enter any username/password into it.  And from my research there seems to be no username/password combo (network, local admin) that will work.


I am pretty sure that this is this is a Windows only problem, because I can still connect to anything on my network (including the NAS) using either of my Macs - and they connect as my PC used to - instantly.

 I spent an hour + on the phone with Western Digital and we ran every test possible - our findings were that the WD NAS is working fine. 

We checked the IP to the Physical address, shut down the WD unit with a soft, then a hard boot. 

Shut down the router and rebooted it as well as checking all LAN connections for connectivity.  All was good. 

 We then tried again to connect to the WD My Cloud EX2. 
Still no luck.

 Lastly I tried to connect to the MacBook Pro, which is on the same network.  That produced the same results as the WD connection failure.  No access at all.


macbook pro error.jpg

So I hope this lets you see what's happening because the situation remains the same, even after reformatting my drive and re-installing the OS.  I will really apppreciate any and all help you can give me.

Thank you in advance.





6 Replies
you may want to check into the SMB settings, and if your NAS supports it changeover to the more secure SMB v3

Not sure if this is you case, it took me quiet a while to get it to work ...


In the Network Credentials box enter a "full-qualfied" username, which includes the name of the endpoint. Then enter the password for this (NAS) identity.

  • Username: WDMYCLOUDEX2\[nas_identity]
  • Password: [nas_identity_password]


Actually I prefer entering these credentials in Credential Manager. Now whenever the connection is restored the right credentials are used.

  1. Select "Start"
  2. Enter "Credential Manager"
  3. Select "Windows Credentials"


Again, include the device the (local) domain, -eq NAS, with the User name.


Hope this helps.


I have the SAME issue and the full name (TREYS-APPLE\trey(username)) with normal log on PW did not work.  I can see the Win 10 PC on the iMac but not the reverse !!

Hi William,


Not sure if I understand your question. Are you trying to connect your Win10 device to your iMac, meaning you iMac acts as an SMB server on you (local) network? No experience with iMac's though so I recommend to check this first


Then see if this works:

  1. Open CMD prompt
  2. Type "NET USE * \\TREYS-APPLE\[sharename]". You will be prompted for username and password. Username should be full qualified. The password is your iMac username password.
  3. If this works, then enter these same credential is Credential Manager. If this fails, something else needs to be figured out, for example share and/or identity information is spelled wrong.


@Wim van Wieren That was it for me. Windows Credential Manager stored a password separate from our Ubuntu machine or samba user, so by resetting the password there, the Enter Network Credential no longer popped up. Thank you for the solution.

Glad it helped, thats what the community is for ;)