Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)

Windows 10 Update destroyed my Ethernet Adapter Driver?

New Contributor

Yesterday, after I played some games I installed some Windows Updates (September 14, 2021—KB5005565) and shut down my PC. Today, I started my PC and ... no Internet connection while the LAN was available. I tried pretty much everything: turned off the firewall, set static IP address, DNS, Default Gateway for my subnet, disabled IPv6 (I was frustrated), uninstalled Windows Feature and Quality Updates and my Networking Adapter's Driver. I tried the WiFi from another device (worked) and tried it via an Ethernet Wire from my Playstation (worked). Of course restarting the router several times, tried different ports and so on.

However, nothing worked. Btw, it wasn't just a DNS issue, but some Routing issue (ping 8.8.8.8 worked neither). Then I tried to connect via NordVPN and, well, my PC was online again O.o. I'd have never thought that this would work. 

 

Coming back to you, can anyone say if I'm right with my Driver/Update cause? Or perhaps something else?

5 Replies

@Eiffelsturm 

Hi, this update is needed especially because of security, I do not think that it was a problem with the driver - often the system needs some time for a full reinstallation and you also have to be patient without acting hastily.
Sometimes it is enough to restart twice .

I totally agree! That‘s why I did several reboots between my tries and waited a lot. However, it‘s solved. But I thought one of you has had the same issue and perhaps knows what exactly caused this problem :)
Yes, but without resetting the Wifi network I disconnect the connection and then - connect automatically - the worst thing is to do unnecessary activities.

Today we are the 22nd of June 2022.
I have the same problem.
Not sure that what I read here can help because when an update "destroyed" my Ethernet Adapter, it just means, in my case, that we can use the WiFi but not the Ethernet, and in my case, wired PCs are more important than WiFi.

So if there would be somebody less calm and judgmental about how a person's freaking when this happen could find us a solution, that works, because I waited and rebooted many times and the problem started right after an update, 3 weeks ago. I didn't have time to take care of it so, yes, I took the time and stayed calm but still today I only see the 3 curved lines and a dot and this prevent me from using my 1Gbps speed for transfer.

This morning I went to Device Manager, un installed all network adapter and rebooted. They all came back in a minute and I still have the same problem.

My cable is connected directly to the PC, I can see the lights lit at the switch and behind the cable connector on the PC, the Network Settings, Ethernet says UnIdentified network (No Internet). The second Ethernet 3 is not connected.

I'll keep digging but anytime you know about a solution, it'll be appreciated to get a reply.

Thanks guys.