Steelseries Merc Keyboard - Extended Keys unwanted new behaviors.

Copper Contributor



       Recently got the Windows 10 creators update for my PC.  Aside from having to remove and rediscover my Sound Card, I am noticing this little annoying issue.   This Keyboard (MERC SteelSeries by Ideazon)  has an additional set of keys on the Left-hand side that offer the same functionals as a Gaming Pad  Partial Qwerty, Numerpad Space, ETC.    I am not getting this to work like it did before.   Example  Prior to Update the WSAD keys worked as they did in every other game, they were movement keys, there were combos setup IN GAME that would allow me to do other things.   Post Update - Pressing the WSAD opens other windows features, most notably pressing the "W" open Microsoft Edge, and pressing the tab key opens Calculator.   This has, of course, happened on the weekend when my downtime is most needed. Anyone have any suggestions on how to correct this?  


My thanks.  



15 Replies

I have the same keyboard and same problems.  I find that the extended W key now activates WWW Home, the  extended S, WWW Stop, extended A key, WWW Refresh, extended D key, WWW Forward.  I have checked the Z engine driver software and WSAD extended keys are scripted for the WSAD keys.   No idea why the extended keys have changed.

I checked the keyboard drivers. The keyboard is using the Microsoft drivers and there is no option to rollback to Mfg. keyboard drivers. Appears no longer supported. The key codes don't show up on any mapping software I could find so there may be no solution for a while. I changed to an old gaming keyboard that works ok, so I will be going that route for now.
I tried plugging the keyboard into a usb2 slot. It is working now. If you don't have a usb2, you may find and old add-on card and try that.

I've switched my keyboard to a usb2 slot without any improvements. Has anyone else gotten this to work?

Extremely doubtful you're going to get any useful responses when posting something like this in the Microsoft Teams section of the Tech Community.


I believe you're looking for the Windows 10 section:


Good luck!

I just ran into the same issue today. The keyboard worked (special keys) yesterday and today it does not. The three updates made to the system where: KB4034674, KB4034662 and KB890830. I cannot locate what would have caused this in the updates but my left hand keys are now mapped wrong like yours. What's weird is that there are no driver changes made to the keyboard, so it has to be something in windows OS settings. If anyone figures this out please post the fix. I love this keyboard and don't want to lose it.
Edit: Everyone should find that they have an error (876) in event viewer (system) with this file name displayed: Alpham164.sys. It will also be followed by another warn message (219) indicating that the driver Alpham1 failed to load. I was fine until this error appeared. The file is a Idealzon keyboard driver and it fails to load after one of the updates and a reboot. 

This is the rror, sorry it´s in spanish, and sorry for my english. After the update, windows block this driver.



My Merc keyboard is still working after having this problem.  I had tried un-installing and re-installing the Mfg driver ZE_25030_NA_64.exe.  I then tried the Microsoft Mouse and Keyboard software but it didn't see a supported keyboard.  I had another gaming board installed at the time but have since removed it.  I then unplugged the Merc and plugged into a ps2 port.  It detected the Merc and installed.  At that time it started working.  It is still using the Microsoft drivers but the extended keys work properly.  Also, in devices it shows up as 2 keyboards.  I presume the one showing as Merc is the extended keyboard.

Thanks Dewey. I will try and use a usb to Ps2 adapter and see if that works. Based on what I looked at with the drivers, I have a feeling that useing a USB 2.0 port may also solve the issue. Unfortunatly, I dont have any usb2 ports on my system to test this out. 

It seems alpham164.sys driver is being blocked and preventing my Steelseries Merc keyboard from working. Is there anyway to get a hotfix to fix this problem seeing as Steelseries is no longer updating their Merc drivers?

Here was my fix for this, after uninstalling the update(s) that blocked Alpham and realizing that's going to be a never ending task as cumulative updates keep rolling in (even with the wusho... "don't install this update" utility).  My solution was to reinstall/install the driver but under a different name.  


Here were my steps (some may be skippable).  


All Settings -> System ->  Update & Security -> Recovery -> Advanced Startup, continue prompts to use option 7 to start Windows without signed driver enforcement


After reboot, in your C: programs (x86) > Ideazon > Zengine > copy the Kernel2k directory to preserve an original untampered version.

In the Kernel2K dir, rename every file that starts with Alpham*/alpham* to something else (ex. Alpham1.sys => Merc1.sys).  Open the renamed .inf  file in a text editor (Sublime, etc)  and do a similar find and replace  on "Alpham" replacing with "Merc" (or whatever you used), replace all.


In device manager for the keyboard -> update driver -> Browse Computer -> Let me pick -> Have Disk -> Browse -> manually select your newly renamed .inf file.  Click ok or whatever on the "Unsigned driver Warning".  


It'll install the same drivers as Merc164.sys and windows won't flag it as contraban, the red Z will go green and yay - I play games again without buying some $200 orbweaver, taking 3/4 my gaming time uninstalling updates, or attempting to forego updates from now until forever.  Solution might require restarting in the Recovery -> Start without driver signing enforcement after a reboot, but that's tolerable until a better option exists.  

How did you update the security catalog with the new hash?

I'm getting "The has for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering."

Too bad I can't just tell it that the tampering is intentional!

What Ty Acker posted above works perfectly! Here's some minor clarifications based on my execution of it:


First, disabling signed driver enforcement only works until the next reboot; I'd wait until just before driver installation to disable it. (Once your driver is installed, you will no longer need it disabled, so future reboots won't re-disable your keyboard). A good step-by-step guide is here:


Next, you need to create a new cat file from the edited .inf file. After renaming the alpham files to merc, delete the (or after the rename, it's the Security Catalog file). Now we need to generate a new security catalog for our edited .inf file using inf2cat from the Windows Driver Kit (found Of note, it's going to give you a number of warnings during install that you won't be able to develop drivers since you don't have an IDE installed. Just OK through them... you're not developing a driver.


Of note, make sure you add the WDK installation location to your PATH variables. Type path in search and select "Edit environment variables for your account" then select Path in the top window and click edit. Click new then add the directory of your inf2cat.exe file. Mine was in D:\Program Files (x86)\Windows Kits\10\bin\x86. Hit enter, then OK all open windows.


To actually generate the .cat file, open a Command Prompt and type:

inf2cat /driver:"path" /os:10_X64, 10_X86


where "path" is the directory of merc.inf. So, for me it was inf2cat /driver:"D:\Program Files\Ideazon\ZEngine\Kernel2k" /os:10_X64, 10_X86


Now that you have the .cat file created, disable signed driver enforcement and use Ty Acker's process to actually install your drivers.


Final note: In device manager, my merc was showing up under Human Interface Devices, not Keyboards. You should install your new driver for both "Ideazon Merc MM USB Human Interface Device" and "Ideazon Merc USB Human Interface Device"


Thanks again to Ty Acker for sharing his solution!

2 years on still got the same issue can anyone help me sort this out as recently came across this keyboard in my attic and works perfectly and is in amazing condition. I am trying to sort out the issue I have for it but likes like this was still a windows issue a year ago as well. If the fix has been done by now can anyone please lend me a hand and sit on teamviewer and skype with me? @Marvin J. McHardy 

Microsoft Power Toys app somewhat solves the issue. The old unsigned drivers and side loading of drivers no longer seems to work. With MS Power Toys you can rebind many of the keys on the Zmerc and possibly the Merc and Steelseries. However, the ability to hold down multiple keys appears to be broken if you use Power Toys to rebind the dedicated butterfly keys. What boggles my mind is that no other keyboard manufacturer has bothered to bring these keyboards back, surely there is money to be made by selling dedicated gaming keyboards like this.