"Can't connect to this network." "Media disconnected" no networking hardware detected

Copper Contributor

Hi Folks,

First time here, hope I'm doing this right.

Dell Inspiron, 5755, Windows 10 home. Since it's arrival, I've been plagued with this same problem. It's got to the point that I never shut it off anymore, because too often when I boot it back up, this problem appears again... and I still have no idea how to fix it (seems that something different fixes it each time... )

What I've done so far: tried updating drivers; most recent already installed. Device manager says device(s) are working properly, no yellow ! signs. Network troubleshooter merely states that I have not chosen to connect to an available network (wifi is on, by the way, and networks are available). Other devices in house running without problem, so router/connection is fine. This same machine works flawlessly if booted into Linux (maybe I should just give up and switch to a less troublesome OS....) Disabled/re-enabled devices... no good. Uninstalled devices /rebooted... no good. Tried a slew of networking commands from the command line (as administrator): netsh winsock reset, netsh int ip reset, ipconfig /release ("no operation can be performed with media disconnected"), ipconfig /renew (same error message), ipconfig /flushdns, netsh int ip reset reset.log hit, ... and rebooted; none of this made any difference. Tried resetting network in Win10 networking troubleshooting... now Windows can't even detect any networking hardware onboard.

Can't connect wirelessly, obviously, also can't connect with a wired LAN cable... it's just dead in the water as far as networking of any kind goes. The only way I got here, now, was to reboot the machine into Linux so I could create this post.

Can anyone tell me which reports to create (like ipconfig /all, netsh wlan show wlanreport, and any others that would be of help to you all in diagnosing this persistent, massively annoying problem? Hopefully so that WHEN it happens again (as MS seems to be unable or uninterested in fixing this widespread problem) I will actually know what to do instead of flailing around all over MS support / internet forums looking for something, anything that might get it working again? Every time this happens I have to go through the same process all over again... like a guy who's trying to fix his car, and somebody tells him to replace a part, and he does, and it now works... but he has no idea WHY it worked, and if he has further problems, and the fix he tried last time didn't work this time, he's once again stuck with no idea why it won't run. That's me in a nutshell with this issue.

Thanks so much for any help on this... I don't even necessarily want the issue to go away so much as I want to be able to fix it without too much trouble when it recurs, rather than go through another week-long ordeal. So much appreciated!!

7 Replies
most laptops have a small button somewhere on them that can be used to turn on/of WIFI and other radio devices such as Bluetooth.
did you check if yours got one?

@HotCakeX:  Hey, thanks for the reply.  Yes, it's the first thing I checked, as I've done it before.  Last laptop had an "open" key for network disconnect (you could hit it and no network); this one you have to hit "Fn" plus the key, so it's a lot harder to do accidentally; it's a good feature that all laptops should have, in my opinion.


Of late, when this stupid "can't connect to this network" (which is about as informative as nothing at all) occurs, usually after an "update," power-cycling the laptop seems to clear it up.  I don't know if that's the "fix" for the problem, or what might have changed, but that never worked before.  It's done this since I opened the box; day one, I had to call Dell support to get wireless internet back.  Not impressed, Dell... not impressed.

That must be annoying as hell.
I have an old Sony laptop (from 2010-2011) that I always keep updated and install every new Windows 10 version as soon as they come out on it (currently version 1909)
So I wanted to ask which version of Windows 10 are you using?

@HotCakeX:  System says it's running version 1809, build # 17763.914.  I don't bother to chase the updates, as this thing is always updating itself whether I want it to or not.  Some things are so slow to load (Win10 being one of them) that I generally just shut the lid and leave it on, and pick up where I left off when I want to use it next.  I can tell when it's updated, because when I go to use it, I'm looking at a Linux log-in screen (dual-boot system, Win 10 & Linux Mint, defaults to Linux.)  Mostly I use Windows for gaming, don't have a whole lot of use for it otherwise; it's rude, intrusive, and thinks it owns my PC.  Linux is far more polite and does it's thing in the background, transparently, when it needs to do something... a lesson Microsoft could and should take to heart.

Doesn't look like your Windows owns your computer nor does it update on its own though..
Because it let you install a different OS and also right now the latest build is 1909 and each one (1903 and 1909) brought so much more features and fixes with themselves.
the only OS that thinks it owns your computer is Mac OSX.

@HotCakeX:  Weelllll... technically I own it, but Windows seems to think that IT owns it, in that it simply barges in and updates whenever it feels like it (as I mentioned, I go to use it and am looking at a Linux login... so it updated, without my permission to do so... and all game progress is lost, open documents that were in progress, any changes are lost, etc.  Annoying.)


In no way did it LET me install another OS... I had to use a backhoe and jackhammer to set this thing up as a dual-boot... Dell refused to help me with it in any way, wouldn't even discuss existing BIOS settings/options (which is why this is the last Dell I'll ever buy....)  Had to dig out the way to do it entirely on my own.  Windows doesn't 'allow' anything; it's entirely ignorant of another OS going in (and you have to make sure Windows goes in first; if you install Linux first, Windows doesn't bother to check for an existing OS... it just barges in and sets up housekeeping, trashing whatever might have already been there.  Linux plays much more nicely with others, and installs itself alongside the existing OS.  Much more well-mannered and considerate than Windows ever was.


Can't speak to Apple... they're so ludicrously expensive that I never even looked at them.  Plus, I was aware that the OS is pretty much a "black box" as far as the user goes... can't open the hood and mess around, just passively use what's offered.

The auto updating problem was there for a period of time but if you upgrade to 1903 or 1909, they are no longer there.

Thanks for the insights about the Dell, I will remember that next time I'm buying a laptop, i will probably go for Asus ;)
the problem you were having was related to the bootloader, if you ever get into the same situation again we can solve it quick by making the 2 OSes known to the bootloader.