SOLVED

PROBLEM: USB and Touchscreen do not work

%3CLINGO-SUB%20id%3D%22lingo-sub-447493%22%20slang%3D%22en-US%22%3EPROBLEM%3A%20USB%20and%20Touchscreen%20do%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-447493%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20running%20an%20ASUS%20x202E%2C%20with%20a%20Pentium%20(2117U%20%40%201.80GHz)%20Processor%2C%204%20Gigabytes%20of%20Ram%2C%20and%20a%20500GB%20HDD.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Emy%20version%20of%20windows%20is%3A%20(Windows%2010%20x64%20Home%20Edition)%20Windows%2010%20Version%201803%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eall%20of%20my%20USB%20ports%20in%20Device%20Manager%20are%20marked%20with%20a%20yellow%20triangle%2C%20and%20uninstalling%20the%20devices%20did%20not%20work.%3C%2FP%3E%3CP%3Ealso%2C%20Windows%20has%20not%20updated%20in%20a%20while%2C%20and%20when%20it%20tries%20to%20update%2C%20it%20says%20%22could%20not%20complete%20the%20changes%2C%20reverting%20changes.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20no%20restore%20point%2C%20as%20I%20was%20an%20idiot%20and%20didn't%20make%20one%3B%3C%2FP%3E%3CP%3EMy%20touchscreen%20is%20not%20showing%20up%20in%20device%20manager%20at%20all%2C%20even%20when%20I%20click%20%22show%20hidden%20devices%22.%3C%2FP%3E%3CP%3EI%20also%20tried%20to%20reinstall%20the%20driver%20for%20the%20touchscreen%2C%20but%20I%20could%20not%20find%20the%20driver.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethe%20drivers%20that%20are%20not%20working%20are%3A%3C%2FP%3E%3CUL%3E%3CLI%3EIntel(R)%207%20Series%2FC216%20Chipset%20Family%20USB%20Enhanced%20Host%20Controller%20-%201E2D%3C%2FLI%3E%3CLI%3EIntel(R)%207%20Series%2FC216%20Chipset%20Family%20USB%20Enhanced%20Host%20Controller%20-%201E26%3C%2FLI%3E%3CLI%3EUSB%20xHCI%20Compliant%20Host%20Controller%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%2C%20when%20I%20try%20and%20view%20the%20Human%20Interface%20Adapters%2C%20there%20is%20only%20one%20thing%20there%2C%20even%20under%20the%20%22show%20hidden%20devices%22%20option.%20(there%20should%20be%20more%2C%20with%20one%20denoting%20the%20presence%20of%20the%20touchscreen%2C%20in%20some%20form.)%26nbsp%3B%3C%2FP%3E%3CP%3Ethe%20name%20of%20this%20device%20is%3A%3C%2FP%3E%3CUL%3E%3CLI%3EHID-Compliant%20wireless%20radio%20controls%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20on%20this%20issue%20would%20be%20appreciated!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPS%3A%3C%2FP%3E%3CP%3Esolutions%20I've%20already%20tried%3A%3C%2FP%3E%3CUL%3E%3CLI%3Ereset%20Windows%2C%20and%20do%20a%20full%20wipe%3C%2FLI%3E%3CLI%3Euninstall%20the%20devices%2C%20and%20then%20reinstall%20them%20directly%20from%20the%20manufacturer's%20website%20(Intel)%3C%2FLI%3E%3CLI%3EI've%20already%20checked%20the%20physical%20hardware%20inside%20the%20case%2C%20and%20it%20appears%20to%20be%20fine%3C%2FLI%3E%3CLI%3Edisk%20check%20(via%20command%20terminal)%20shows%20no%20errors%3C%2FLI%3E%3CLI%3Edid%20multiple%20malware%20scans%2C%20with%20the%20highest%20level%20of%20scanning%20possible%2C%20and%20nothing%20came%20back%20as%20malware%2C%20PUPs%2C%20or%20any%20other%20malignant%20software.%3C%2FLI%3E%3C%2FUL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1077001%22%20slang%3D%22en-US%22%3ERe%3A%20PROBLEM%3A%20USB%20and%20Touchscreen%20do%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1077001%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Etry%20installing%20the%20latest%20Windows%2010%20version%20(1909)%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fsoftware-download%2Fwindows10%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fsoftware-download%2Fwindows10%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3Ethen%20install%20the%20latest%20Intel%20INF%20so%20that%20your%20OS%20will%20know%20exactly%20what%20hardware%20is%20inside%20your%20computer%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdownloadcenter.intel.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdownloadcenter.intel.com%2F%3C%2FA%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdownloadcenter.intel.com%2Fproduct%2F53%2FChipsets%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdownloadcenter.intel.com%2Fproduct%2F53%2FChipsets%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1077072%22%20slang%3D%22en-US%22%3ERe%3A%20PROBLEM%3A%20USB%20and%20Touchscreen%20do%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1077072%22%20slang%3D%22en-US%22%3Ethank%20you%20so%20much.%3CBR%20%2F%3E%3CBR%20%2F%3Ei%20was%20beginning%20to%20wonder%20if%20anyone%20was%20going%20to%20answer.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1077088%22%20slang%3D%22en-US%22%3ERe%3A%20PROBLEM%3A%20USB%20and%20Touchscreen%20do%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1077088%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3CBR%20%2F%3Eyou're%20welcome%20and%20sorry%20about%20the%20late%20reply.%20happy%20early%20Christmas%20though%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I am running an ASUS x202E, with a Pentium (2117U @ 1.80GHz) Processor, 4 Gigabytes of Ram, and a 500GB HDD.

 

my version of windows is: (Windows 10 x64 Home Edition) Windows 10 Version 1803 

 

all of my USB ports in Device Manager are marked with a yellow triangle, and uninstalling the devices did not work.

also, Windows has not updated in a while, and when it tries to update, it says "could not complete the changes, reverting changes."

 

I have no restore point, as I was an idiot and didn't make one;

My touchscreen is not showing up in device manager at all, even when I click "show hidden devices".

I also tried to reinstall the driver for the touchscreen, but I could not find the driver.

 

the drivers that are not working are:

  • Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E2D
  • Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26
  • USB xHCI Compliant Host Controller

 

Also, when I try and view the Human Interface Adapters, there is only one thing there, even under the "show hidden devices" option. (there should be more, with one denoting the presence of the touchscreen, in some form.) 

the name of this device is:

  • HID-Compliant wireless radio controls

 

Any help on this issue would be appreciated!

 

PS:

solutions I've already tried:

  • reset Windows, and do a full wipe
  • uninstall the devices, and then reinstall them directly from the manufacturer's website (Intel)
  • I've already checked the physical hardware inside the case, and it appears to be fine
  • disk check (via command terminal) shows no errors
  • did multiple malware scans, with the highest level of scanning possible, and nothing came back as malware, PUPs, or any other malignant software.
3 Replies
Best Response confirmed by Anthony_Gerdes (New Contributor)
Solution
Hi,
try installing the latest Windows 10 version (1909):
https://www.microsoft.com/en-us/software-download/windows10

then install the latest Intel INF so that your OS will know exactly what hardware is inside your computer:
https://downloadcenter.intel.com/
https://downloadcenter.intel.com/product/53/Chipsets
thank you so much.

i was beginning to wonder if anyone was going to answer.

Hi,
you're welcome and sorry about the late reply. happy early Christmas though :)