MS Store DCOM Error

Highlighted
New Contributor

I'm getting the error "Unable to start a DCOM Server: Microsoft.WindowsStore_11910.1002.5.0_x64__8wekyb3d8bbwe!App as Unavailable/Unavailable. The error: "2147942402" Happened while starting this command: "C:\Program Files\WindowsApps\Microsoft.WindowsStore_11910.1002.5.0_x64__8wekyb3d8bbwe\WinStore.App.exe" -ServerName:App.AppXc75wvwned5vhz4xyxxecvgdjhdkgsdza.mca" when I try to run Microsoft Store after KB4549951 (v.1909 OS Build 18363.752 -> OS Build 18363.778). 
Store worked fine before.

To see what’s wrong with the server - I looked in Component Services (C:\Windows\system32\comexp.msc ) - but there is no such servers with suitable names, and I didn’t find it by searching by AppID.
Then I did a registry search for the key phrase "WinStore.App.exe". There are keys with parameters in the registry where "WinStore.App.exe" is mentioned, but neither the AppID nor the CLSID of the corresponding DCOM server  in the registry, as it should be.
Then I did wmic dcomapp> e: \ DCOM_list.txt. In the list there no Microsoft.WindowsStore_11910.1002.5.0_x64__8wekyb3d8bbwe! App server or similar .

What is this server and why is it not in the system?

 

Now I already have Windows 10 Pro v.2004 OS Build 19041.329, but the MS Store problem has not been solved so far.

sfc /scannow - no problem

PowerShell  Repair-WindowsImage -Online -RestoreHealth - Helth

DISM /Online /Cleanup-Image /RestoreHealth /source:H:\install.esd:6 - no problem.

PowerShell Get-Appxpackage ->

PackageFullName: Microsoft.WindowsStore_11910.1002.5.0_x64__8wekyb3d8bbwe
SignatureKind: Store
Status: Ok
In-place upgrade with MediaСreationTool - did it twice - does not help.

And that’s weird ...

In MCT (from https://www.microsoft.com/en-us/software-download/windows10) in \sources\install.esd\6\Program Files\WindowsApps, the version of the MS Store package is 11910.1002.5.0 (Microsoft.WindowsStore_11910.1002.5.0_x64__8wekyb3d8bbwe).

 

While people who also updated 2020.05.28 to v.2004 OS Build 19041.264 (I asked in other forums) the version of the MS Store package 12005.1001.1.0 (MS Store Microsoft.WindowsStore_12005.1001.1.0_x64__8wekyb3d8bbwe)

So the new MS Store 12005.1001.1.0 package was downloaded and installed when upgrading to v.2004 OS Build 19041.264 for those people.
I don’t understand why my MS Store package is not updated to 12005.1001.1.0, but the version of the package that is in the v.2004 OS Build 19041.264 image and which does not work properly is installed.
What's wrong?

2 Replies
Highlighted

Hello @Jon Lord, 

 

Try re-registering Store app. Perform these steps: 

 

1. Search for Windows PowerShell using Cortana or Windows Search. 

 

2. From results, right click on Windows PowerShell and select Run as administrator. 

 

3. Then type following command and press Enter key: 

 

Get-AppXPackage *WindowsStore* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 

 

Let the command complete. 

 

4. Close Windows PowerShell. 

 

See if it helps in this case!

Highlighted

 
Already done and more than once.
You can read more with google translate here post LV-223 #43906 08.06.20 13:45