Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

How to remove "Some settings are managed by your organization" on Windows 2019 DC

Copper Contributor

One of our clients has upgraded their Windows 2012 R2 DC to 2019. The Windows Update shows  "Some settings are managed by your organization". They wanders how remove this message. I have tried these.



1. Run gpedit.msc and make sure All Settings are No configured.

2. Run  gpedit.msc. Enabled Allow Telemetry wit 3-Full. Then disable. I tries that a couple times and run gpupdate /force.

3. Changing Registry Setting: changed NoToastApplicationNotification vvalue from 1 to 0.

4. Changed Privacy" -> "Feedback & diagnostics from Basic to Full. 


None of them fixes the problem. Any suggestions?


41 Replies
Having exactly the same issue with Server 2016.
GPO was originally set to Remove Access to all Windows Update Features.
This has now been disabled, local gpedit settings all Not configured, WindowsUpdate registry keys removed.
Still getting Managed by Organisation.

Fixed the old fashioned way.

Disable Windows Update service


Delete contents of c:\windows\software distribution

Turn Windows Update service back to manual

Check for updates


All working fine now.




Thank you for your suggestion/solution. This worked perfectly for me.

im having the same exact issue besides mine is in account options and your info.

How can I fix Some settings are managed by your organization?


1. Remove work or school accounts

  1. Go to the Windows Settings.
  2. Click on Accounts.
  3. Go to Access work or school.
  4. Select any connected account and remove it.
  5. Restart your device.


Deleting this reg entry fixed the problem for me.  Thank you

@Bob Lin 

Please try this people. It solved it for me. It took me 4 hours to find this fix. I trasnlated it from's a bit amateuristic but it should be clear.

Policies recovery in Windows 10

  • Click right mouse button on Desktop > New > Textdocument.
  • Open this file and place it with the script below to restore all policies.
reg delete "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies" /f 
reg delete "HKCU\Software\Microsoft\WindowsSelfHost" /f 
reg delete "HKCU\Software\Policies" /f 
reg delete "HKLM\Software\Microsoft\Policies" /f 
reg delete "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies" /f 
reg delete "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsStore\WindowsUpdate" /f
reg delete "HKLM\Software\Microsoft\WindowsSelfHost" /f 
reg delete "HKLM\Software\Policies" /f 
reg delete "HKLM\Software\WOW6432Node\Microsoft\Policies" /f 
reg delete "HKLM\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Policies" /f 
reg delete "HKLM\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\WindowsStore\WindowsUpdate" /f
  • Click in notepad screen on File > Save as.
  • Change in save option below “Textdocuments (*.txt) to All files.
  • Save file as ResetPolicies.bat.
  • Click rightmouse button on this file and choose option Execute as administrator.
  • Commandprompt opens and automatically changes all lines in the register.
  • Restart PC to get all the changes to work.
Can confirm this work after trying:
- GPE setting
- Disconnect Work/School account
to no avail.
Please create restore point prior to attempting this solution

I found that resetting all my local group settings in command prompt worked.


Scroll down to the section that says, "How to reset all Local Group Policy settings using Command Prompt"




Being honest tried every thing non of that works. Till i clicked in Accounts "Access work or school" link the account then just unlink that. All solved i think was just a bug to me.
Thank you! This is what fixed it for me. None of the Group Edit things were ever set to enable in the first place so the other solutions did not apply to me.
Dude, your the man I been combing the net for fixes for my issue and this was the one that nailed it for me. There are too many videos on Youtube showing the same stupid thing. Thank you so Much!

Set "disabled" at "configure automatic updates" gpedit.msc in Windows Server 2022 clean installation

Then, set "not configure". That works!

Great, this is what was needed in my situation. The Default stock options everyone else posted did not work.