SOLVED

Help me! Slow issues with the latest Windows 10 update (May)

Highlighted
Occasional Contributor

Good morning to the whole community.
I have a DELL Latitude 7280 laptop with 8GB RAM and 512GB SSD.
After the last update of Windows 10 of May I am experiencing significant slowness problems that force me to frequent freezes and the need to restart the PC.
The problem suddenly manifests itself while I am working, by launching any application the system slows inexorably and seems to stop completely. In reality, by waiting several minutes (sometimes even hours), the system completes its operations. It is clear that in this way the system is unusable.
I tried to check the drivers, I repeatedly reinstalled the operating system but without success.
I would like to understand if other users have had the same problem and what it can depend on.
I have absolutely no idea where to look to understand the nature of the problem!
Please help me because I'm stuck!
Thank you all

4 Replies
Highlighted
Best Response confirmed by FCatalano (Occasional Contributor)
Solution

Surfing the net in a frantic way I found this article:
https://www.laptopmag.com/news/windows-10-update-is-causing-serious-problems-for-these-users-heres-a...
How much truth is there in this article?
I tried to remove "Intel Optane Pinning Explorer Extensions" and the laptop seems to be working properly.
What am I missing?
Is that program I removed important?
Can I solve it another way?
Thanks for the attention.

Highlighted

Unfortunately, despite appearances, the problem has not been resolved. :cry:
I want to specify that the only anomalous thing I am noticing is a notable delay in recognizing the network at boot time but I repeat that the drivers are all up to date.
Regards

Highlighted

After a couple of days of testing I can say that I have solved the problem!
The solution to remove the Optane drivers therefore remains valid.
Thanks anyway to everyone.
Regards

Highlighted

We are a Dell shop and we ran into the same issue along with BSOD's referencing the Intel Optane driver on Dell Latitude 5401 notebooks. Dell has a link that we are now using after an employee updates to build 2004 and this will correct the Optane issue as well, but with this link you are still using the Intel Optane software, just an older useable version of it. Good luck!

https://www.dell.com/support/article/en-us/sln322012/resolving-the-intel-optane-memory-pinning-error...